summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-08 08:29:29 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-08 08:55:21 +0200
commit5d33d935155223800a2429e4d01ca25917dc1d51 (patch)
tree76e21fa5ec16e7e730c64fe5e08459c027c545ff /dev-python/coreschema
parentdev-python/pytest-lazy-fixture: Add python@ as co-maint. (diff)
downloadgentoo-5d33d935155223800a2429e4d01ca25917dc1d51.tar.gz
gentoo-5d33d935155223800a2429e4d01ca25917dc1d51.tar.bz2
gentoo-5d33d935155223800a2429e4d01ca25917dc1d51.zip
dev-python/coreschema: Port to py3.10, enable tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/coreschema')
-rw-r--r--dev-python/coreschema/Manifest2
-rw-r--r--dev-python/coreschema/coreschema-0.0.4.ebuild15
2 files changed, 10 insertions, 7 deletions
diff --git a/dev-python/coreschema/Manifest b/dev-python/coreschema/Manifest
index 49890493f062..dde371908d51 100644
--- a/dev-python/coreschema/Manifest
+++ b/dev-python/coreschema/Manifest
@@ -1 +1 @@
-DIST coreschema-0.0.4.tar.gz 10974 BLAKE2B 8bddafea9eb82140cdf2b2cd40ffc31dd4a0457f8ca216986807657a5021f7a4319f1e3db27caf7d471f8617f6f0c3a6d79ebfe7e0285bc9a6627f93d6efa760 SHA512 21a35b29cd0bb96dacaeeb0bd0faaaa4ee8875bf9639b431b59f17c41ee4829173932a6b35760caa3b46a0ec39ca173fe896b26b740fe97df36943270bc2bd3d
+DIST python-coreschema-0.0.4.tar.gz 21905 BLAKE2B 1afe09038761809fa0e12d13fb89884760d4aff325a4bbdac104c03648856f8d50b562fc00a8509fcc75f962918f33d89017fae0a6d0335def4d6b77ee9aacd9 SHA512 28badbae07284fb4dbd3f01f613edda1202902115fb166bd95bbac549d398c9e02548b473524d3b530a42319a99d7e55e92bf54269827a9812249cfb285670c3
diff --git a/dev-python/coreschema/coreschema-0.0.4.ebuild b/dev-python/coreschema/coreschema-0.0.4.ebuild
index c9e4efbc99e9..9dd5057cd50c 100644
--- a/dev-python/coreschema/coreschema-0.0.4.ebuild
+++ b/dev-python/coreschema/coreschema-0.0.4.ebuild
@@ -1,20 +1,23 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
+MY_P=python-${P}
DESCRIPTION="Core Schema"
HOMEPAGE="https://github.com/core-api/python-coreschema"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="
+ https://github.com/core-api/python-coreschema/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest