summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-12 13:02:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-12 13:37:36 +0200
commit51dedb83d09cd9f9b8ead8a3dd822b9b8da26560 (patch)
tree420c6af878a229fd1c090d2252ac1b833bf15f35 /dev-python/cairocffi
parentdev-python/imageio: Bump to 2.31.1 (diff)
downloadgentoo-51dedb83d09cd9f9b8ead8a3dd822b9b8da26560.tar.gz
gentoo-51dedb83d09cd9f9b8ead8a3dd822b9b8da26560.tar.bz2
gentoo-51dedb83d09cd9f9b8ead8a3dd822b9b8da26560.zip
dev-python/cairocffi: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cairocffi')
-rw-r--r--dev-python/cairocffi/Manifest1
-rw-r--r--dev-python/cairocffi/cairocffi-1.6.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/cairocffi/Manifest b/dev-python/cairocffi/Manifest
index f0da0504af18..d10ed0156653 100644
--- a/dev-python/cairocffi/Manifest
+++ b/dev-python/cairocffi/Manifest
@@ -1 +1,2 @@
DIST cairocffi-1.5.1.tar.gz 86924 BLAKE2B 51bbd85ed486d8a324255d7b328fc44490097f0eeb0568d0e9436350e627ee2da7770323d0cfa547da2f007dc097327962d80d0a9a96a2f119bac0bb4aa4d7f4 SHA512 58b33e921866a3db7dfa464514f935f7c615ae3463b852d888e9d221256e91efaa7639001781999bdf68619a725a90de06300973f9e635c7974e8c48729705dc
+DIST cairocffi-1.6.0.tar.gz 86649 BLAKE2B 1ffea1196f9c833f43bfb7e826a634748c3aad47e3b0adbaaf410be74a2e76aa803aa025cf7e0001dafa03cf6425c91614516881c788e1ca740351051b119bb2 SHA512 d46602231f443d8a0b3d46a7e63bb9c8daaee6c24e1c65b071c8b6d22cb96abec7e6c08d38c072f54d223e247e80cef4a562590818e01c8f0b5357bd9c2f29d9
diff --git a/dev-python/cairocffi/cairocffi-1.6.0.ebuild b/dev-python/cairocffi/cairocffi-1.6.0.ebuild
new file mode 100644
index 000000000000..bf9efe570199
--- /dev/null
+++ b/dev-python/cairocffi/cairocffi-1.6.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="CFFI-based drop-in replacement for Pycairo"
+HOMEPAGE="
+ https://github.com/Kozea/cairocffi/
+ https://pypi.org/project/cairocffi/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="
+ >=dev-python/xcffib-0.3.2[${PYTHON_USEDEP}]
+ x11-libs/cairo:0=[X,xcb(+)]
+ x11-libs/gdk-pixbuf[jpeg]
+"
+RDEPEND="
+ ${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]
+ ' 'python*')
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]
+ ' 'python*')
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pikepdf[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.0-tests.patch
+)
+
+src_test() {
+ virtx distutils-r1_src_test
+}