summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-24 21:59:15 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-24 21:59:15 +0300
commit091f3a09fe782a084d186f33126fc7539c204910 (patch)
tree9a1550de17fbfdd69bdb48845477eae19ae5a29d /dev-python/brython
parentdev-python/pyicu: add 2.10.1 (diff)
downloadgentoo-091f3a09fe782a084d186f33126fc7539c204910.tar.gz
gentoo-091f3a09fe782a084d186f33126fc7539c204910.tar.bz2
gentoo-091f3a09fe782a084d186f33126fc7539c204910.zip
dev-python/brython: add 3.11
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/brython')
-rw-r--r--dev-python/brython/Manifest1
-rw-r--r--dev-python/brython/brython-3.11.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/brython/Manifest b/dev-python/brython/Manifest
index 3f4d6ba10270..098c001427a4 100644
--- a/dev-python/brython/Manifest
+++ b/dev-python/brython/Manifest
@@ -1,2 +1,3 @@
DIST brython-3.10.5.tar.gz 11106672 BLAKE2B 4219bdb99efd666e37ee08283e58f288e06dac52454931f72bcb4f3bf61a380fb1e01d724f49e598f6d7a95260609767d4536b5f04531939daaf93db6cdb23ad SHA512 7d2f50f94c9762d6587a9b0ed76805b14a5c2c89c0d27c7e181a3e3abdcdd28c9691fb80cd472f635f5bc6c36c884becd9a5625da4825d551b57b6b0779d3529
+DIST brython-3.11.gh.tar.gz 11684005 BLAKE2B d2ec61082787bbb571fa3a7239bad4e5d633e20f392684c532477d23ab7480dc0c3cd30a837c32fae57c88fa1779afec71bc7adb63bb4abd8f6d2d78717d55ef SHA512 98ee9c8cf1b3f8103310cf08b639fcea6675d178aedde5f425d3b44eac74552e569a8abca8cb6935cfcfc43a009ea73abbc646557a2bda916e5328a8933bea0d
DIST brython-3.9.0.tar.gz 10232037 BLAKE2B 4dc70efa14174f90cddd72ba9c07afd7be4fc81cde3f9ace7b5f015acd4cc18e9ab222aded496523f7298cb7ecb93c1d691fda818ef9fe15fabbb876143af487 SHA512 fcacc6f5e959afd2c84980eb0a650028ad018f4ebda05c53ef0a73ef5a8e1b4a28b2940c08f6b5e82bb52975b671610ad47e42de0d6d3030a6b9f5af02784c20
diff --git a/dev-python/brython/brython-3.11.ebuild b/dev-python/brython/brython-3.11.ebuild
new file mode 100644
index 000000000000..22a048a8d943
--- /dev/null
+++ b/dev-python/brython/brython-3.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit webapp python-single-r1
+
+DESCRIPTION="Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="
+ https://github.com/${PN}-dev/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ dodoc LICENCE.txt README.md
+ rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}