summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2017-12-25 15:56:53 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2017-12-26 02:04:48 +0000
commitf945f64dd446ca45b1fb4cb76377636664e02f54 (patch)
tree0ccfc8fd4ba7aaee08e4882de59cfb5280a87c1f /dev-python/botocore
parentdev-python/boto3: add new 1.5.6 version (diff)
downloadgentoo-f945f64dd446ca45b1fb4cb76377636664e02f54.tar.gz
gentoo-f945f64dd446ca45b1fb4cb76377636664e02f54.tar.bz2
gentoo-f945f64dd446ca45b1fb4cb76377636664e02f54.zip
dev-python/botocore: add live ebuild logic
botocore is released very often - 1.8.0 to 1.8.20 in one month. So it makes sense to allow users to opt in to being up to date, free from ebuild bumps delay. Git master branch is always at latest release, so should be reasonably safe to use. Package-Manager: Portage-2.3.17, Repoman-2.3.6
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/botocore-1.8.20.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/botocore/botocore-1.8.20.ebuild b/dev-python/botocore/botocore-1.8.20.ebuild
index 9e2b1a14bd8e..7f976cb95e55 100644
--- a/dev-python/botocore/botocore-1.8.20.ebuild
+++ b/dev-python/botocore/botocore-1.8.20.ebuild
@@ -8,13 +8,18 @@ inherit distutils-r1
DESCRIPTION="Low-level, data-driven core of boto 3."
HOMEPAGE="https://github.com/boto/botocore"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
RDEPEND="
>=dev-python/docutils-0.10[${PYTHON_USEDEP}]
>=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]