summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-21 08:44:21 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-21 09:54:17 +0200
commitb1a4fdcfcbe4abcf99caaf1cedb5adc300914c82 (patch)
treeb717d4cc10f23e57efff2b8eada8e5ed0e12b03b /dev-python/blessed
parentprofiles/base: Correct experimental LLVM target mask (diff)
downloadgentoo-b1a4fdcfcbe4abcf99caaf1cedb5adc300914c82.tar.gz
gentoo-b1a4fdcfcbe4abcf99caaf1cedb5adc300914c82.tar.bz2
gentoo-b1a4fdcfcbe4abcf99caaf1cedb5adc300914c82.zip
dev-python/blessed: Bump to 1.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/blessed')
-rw-r--r--dev-python/blessed/Manifest1
-rw-r--r--dev-python/blessed/blessed-1.19.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/blessed/Manifest b/dev-python/blessed/Manifest
index 027c75439d48..5688d15577e3 100644
--- a/dev-python/blessed/Manifest
+++ b/dev-python/blessed/Manifest
@@ -1,3 +1,4 @@
DIST blessed-1.17.12.tar.gz 6697754 BLAKE2B 0ae89a587a34936b31114e4bdf77effc51e0ad01b31f3b7e037fe96a44bbfecf1e2f64495d09e2627343f8021116ba1a2d6bccdaac7998b978aebc54e60a7a13 SHA512 134bba81793e8e0e33afcd9daa7453f11857b3207d0427f061ccfc0dd1caa17cff32f84883860f69e2a98ecbb5cc609f2a1091ab7ca8ff42322f6e8466ae06da
DIST blessed-1.18.0.tar.gz 6651519 BLAKE2B e512ae49d19e3db09606e07b6a384683aada3de830e3a8f3e938e088607e4bc33f6b53b3d6477a2b0d4bdeb849fa4cea6eb3b0048294b3a567409a993f46b7dd SHA512 25b0c0c17e82ea975ace3415beb680e7ac917cdd4589ff11f0510067139d2f681316c35a59c7ef9bc5225291cebf6395f0dfc78da8845457ed7cc722ac708bbe
DIST blessed-1.18.1.tar.gz 6651527 BLAKE2B 50667db4fff2eeeb1a238d0634ae3e67ab2323b988db4435174327a894d60fff4988c45cc55a633666d2ed88a8fae4e0844027a0bdc739e63f319ce19319142a SHA512 6b83ff2949ab3f7c5bf599897734092d305beaa21cb70583fcd1a26a42a7f16888813bd281a18905065a9989dbca29cd5a00cc4c75f4e360ab52209fc6d55a4f
+DIST blessed-1.19.0.tar.gz 6653907 BLAKE2B ba9c1247562baed398d6570fa97deeaefc325c502e0aed5907ffaf9802978933e9a5bd6c08b4d4c4a449533272005e3272f70dac5852da1c45c6c9644aee9a56 SHA512 a64d8d542a1a12b710375592c17d06f28a7c68d76952479738873fb956013f7c65820e797116b6151c2a338cd27cfe91b4ad1a318365357060f38d1ec0adf91e
diff --git a/dev-python/blessed/blessed-1.19.0.ebuild b/dev-python/blessed/blessed-1.19.0.ebuild
new file mode 100644
index 000000000000..91051bcb02be
--- /dev/null
+++ b/dev-python/blessed/blessed-1.19.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Library for making terminal apps using colors, keyboard input and positioning"
+HOMEPAGE="https://github.com/jquast/blessed"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Skip those extensions as they don't have a Gentoo package
+ # Remove calls to scripts that generate rst files because they
+ # are not present in the tarball
+ sed -e '/sphinxcontrib.manpage/d' -e '/sphinx_paramlinks/d' \
+ -e '/^for script in/,/runpy.run_path/d' \
+ -i docs/conf.py || die
+ # Requires pytest-xdist and has no value for us
+ sed -i '/^looponfailroots =/d' tox.ini || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # COLORTERM must not be truecolor
+ # See https://github.com/jquast/blessed/issues/162
+ # Ignore coverage options
+ COLORTERM= epytest --override-ini="addopts="
+}