summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-17 11:35:11 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-17 11:36:06 +0100
commit22525f970d958bfe6716eccb00f25e9a4495af97 (patch)
treebe6e8cec7f719dd8466448c4fc15281cda23dde0 /dev-python/binaryornot
parentmedia-tv/v4l-utils: Only check Clang in pkg_pretend when installed (diff)
downloadgentoo-22525f970d958bfe6716eccb00f25e9a4495af97.tar.gz
gentoo-22525f970d958bfe6716eccb00f25e9a4495af97.tar.bz2
gentoo-22525f970d958bfe6716eccb00f25e9a4495af97.zip
dev-python/binaryornot: Use new upstream tarball
Upstream has apparently redone the release. The new tarball removes some unnecessary files (including .pyc files that shouldn't be there) and fixes the version number, so we do not need the patch anymore. Closes: https://bugs.gentoo.org/765688 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/binaryornot')
-rw-r--r--dev-python/binaryornot/Manifest2
-rw-r--r--dev-python/binaryornot/binaryornot-0.4.4-r2.ebuild (renamed from dev-python/binaryornot/binaryornot-0.4.4-r1.ebuild)8
-rw-r--r--dev-python/binaryornot/files/binaryornot-0.4.4-fix-version-number.patch13
3 files changed, 4 insertions, 19 deletions
diff --git a/dev-python/binaryornot/Manifest b/dev-python/binaryornot/Manifest
index c49467b8579f..9e37c8c0ebdb 100644
--- a/dev-python/binaryornot/Manifest
+++ b/dev-python/binaryornot/Manifest
@@ -1 +1 @@
-DIST binaryornot-0.4.4.tar.gz 372361 BLAKE2B cb2099313f602915bacd5b463642f16430fcb0ab62dcaae546cb854780996526fb777c0b730b4b89e664ec7f995ddd2d2f632cfbac2dadca45958cfd1dd7a410 SHA512 31dfb79bb5847e12487d94519a357dece4572f7ed064686d53a49c2de5a51d6441be64523c98cca6221ed89be5bf26e54866dd3b79ac8d89fd5019a5b4d75a45
+DIST binaryornot-0.4.4.r1.tar.gz 371054 BLAKE2B 4a70e22eba51a266987308e8d1b4571ace5760f945920194a1a61f4336f33dcb655c4f0b1f760aa3502834d29a1a64ac62657e5d73eac8f1d7d02edf71db8af9 SHA512 379e71b41824b9389ea02c64223e26c57694d07b749c197e3a6b9f10558c8d502e9b93a13ae6c3a4bca49064ffc650ce822073dc312fb06e50e06b8a3f04f419
diff --git a/dev-python/binaryornot/binaryornot-0.4.4-r1.ebuild b/dev-python/binaryornot/binaryornot-0.4.4-r2.ebuild
index e9e9025051c2..f53260760261 100644
--- a/dev-python/binaryornot/binaryornot-0.4.4-r1.ebuild
+++ b/dev-python/binaryornot/binaryornot-0.4.4-r2.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="Ultra-lightweight pure Python package to guess whether a file is binary or text"
HOMEPAGE="https://github.com/audreyfeldroy/binaryornot"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.r1.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -23,8 +23,6 @@ DOCS=( README.rst HISTORY.rst CONTRIBUTING.rst )
PATCHES=(
# https://github.com/audreyr/binaryornot/commit/38dee57986c6679d9936a1da6f6c8182da3734f8
"${FILESDIR}"/${P}-tests.patch
- # Version number has not been updated to 0.4.4
- "${FILESDIR}"/${P}-fix-version-number.patch
)
distutils_enable_tests unittest
diff --git a/dev-python/binaryornot/files/binaryornot-0.4.4-fix-version-number.patch b/dev-python/binaryornot/files/binaryornot-0.4.4-fix-version-number.patch
deleted file mode 100644
index 05d6ed0b7449..000000000000
--- a/dev-python/binaryornot/files/binaryornot-0.4.4-fix-version-number.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 68a4f5b..a0c9e14 100755
---- a/setup.py
-+++ b/setup.py
-@@ -13,7 +13,7 @@ with open('README.rst') as readme_file:
- with open('HISTORY.rst') as history_file:
- history = history_file.read().replace('.. :changelog:', '')
-
--version = '0.4.3'
-+version = '0.4.4'
-
- if sys.argv[-1] == 'publish':
- os.system('python setup.py sdist bdist_wheel upload')