summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-02 18:58:54 +0000
committerSam James <sam@gentoo.org>2020-08-02 18:58:54 +0000
commitc3b880a3b86f0fa3a3d9ee350654c3ded3a1d2db (patch)
tree525cb96e257410b92ea3a05053d60cd894dba04a /dev-python/babelfish/babelfish-9999.ebuild
parentdev-python/symengine: bump to 0.6.1 (diff)
downloadgentoo-c3b880a3b86f0fa3a3d9ee350654c3ded3a1d2db.tar.gz
gentoo-c3b880a3b86f0fa3a3d9ee350654c3ded3a1d2db.tar.bz2
gentoo-c3b880a3b86f0fa3a3d9ee350654c3ded3a1d2db.zip
dev-python/babelfish: add Python 3.9
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/babelfish/babelfish-9999.ebuild')
-rw-r--r--dev-python/babelfish/babelfish-9999.ebuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/dev-python/babelfish/babelfish-9999.ebuild b/dev-python/babelfish/babelfish-9999.ebuild
index dcc8f1dacc4e..382197499a3f 100644
--- a/dev-python/babelfish/babelfish-9999.ebuild
+++ b/dev-python/babelfish/babelfish-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1 git-r3
@@ -13,12 +13,5 @@ EGIT_REPO_URI="https://github.com/Diaoul/${PN}.git"
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
-IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-python_test() {
- esetup.py test
-}
+distutils_enable_tests setup.py