summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-31 07:49:46 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-31 08:18:42 +0200
commit0c7cb11eb53e16ed2f567fb22c3a20d42fdf5d45 (patch)
tree89cd24e3112436cc11a7f5d777a034da6eadc780 /dev-python/autoprop/autoprop-4.1.0.ebuild
parentdev-python/signature_dispatch: Enable py3.11 (diff)
downloadgentoo-0c7cb11eb53e16ed2f567fb22c3a20d42fdf5d45.tar.gz
gentoo-0c7cb11eb53e16ed2f567fb22c3a20d42fdf5d45.tar.bz2
gentoo-0c7cb11eb53e16ed2f567fb22c3a20d42fdf5d45.zip
dev-python/autoprop: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autoprop/autoprop-4.1.0.ebuild')
-rw-r--r--dev-python/autoprop/autoprop-4.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/autoprop/autoprop-4.1.0.ebuild b/dev-python/autoprop/autoprop-4.1.0.ebuild
new file mode 100644
index 000000000000..c852a7266451
--- /dev/null
+++ b/dev-python/autoprop/autoprop-4.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Infer properties from accessor methods"
+HOMEPAGE="
+ https://github.com/kalekundert/autoprop/
+ https://pypi.org/project/autoprop/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/signature_dispatch-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest