summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-29 06:07:17 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-29 06:13:29 +0200
commite6c9fd42554666887f2cc594832f2e0175c87474 (patch)
treeeb03c94f4ad86a828446e19be68dd46d012fceed /dev-python/autopep8
parentdev-python/google-api-python-client: Bump to 2.131.0 (diff)
downloadgentoo-e6c9fd42554666887f2cc594832f2e0175c87474.tar.gz
gentoo-e6c9fd42554666887f2cc594832f2e0175c87474.tar.bz2
gentoo-e6c9fd42554666887f2cc594832f2e0175c87474.zip
dev-python/autopep8: Bump to 2.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest1
-rw-r--r--dev-python/autopep8/autopep8-2.1.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 9a94e5606a00..d083b5c0a704 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,2 +1,3 @@
DIST autopep8-2.1.0.tar.gz 88891 BLAKE2B 60bd5e9a177d8bdb741b37884bb3ef170fb59664b740beb1b1f38df021dfb7916f2cecdb2e20b6363c2abcc110f9f36902dbccd7f06ddf56f090ccb36149fb19 SHA512 f694a506646b4bc4932fb07cf1c989897e7db3fc9b65dc90886fa657b163dfcbad4c16bb911a2e399a4623b167b313d32213762d3e21e20bff27b6fe2a5abc59
DIST autopep8-2.1.1.tar.gz 91009 BLAKE2B fa324c2c2e827a4bd5c3f60e0fbb83419055a5b0ced7c737b590cdfba9c43f6517ac659bc77212d9694530d42d6ea4c9af642acf5074d514b32a11c62dcc3688 SHA512 cfa9927e44d40d778405fa1a49385c40b79dd425d945ec5053510c594e783f98aaaf083ad53a07b04cf929eac9b274c5a37c8a1256ebb83d897364d40fc9eba0
+DIST autopep8-2.1.2.tar.gz 91299 BLAKE2B a38ed72306d77a517b2f510e46941aa2fe572b4d51e9c8ee9c817798d5e1db964c0f2f436de9be22553557335a9291074870694ca4ac1e054b4cfd9de9db71a5 SHA512 296f3463f5a7088029e4a6cfefcf9b93a8be1798e6c81818d362d801b97d76bb107619c7724d9f1557006223e9514bc5044f2cec24d8c896c7e420431eb2252d
diff --git a/dev-python/autopep8/autopep8-2.1.2.ebuild b/dev-python/autopep8/autopep8-2.1.2.ebuild
new file mode 100644
index 000000000000..6a718a775d3f
--- /dev/null
+++ b/dev-python/autopep8/autopep8-2.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="
+ https://github.com/hhatto/autopep8/
+ https://pypi.org/project/autopep8/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.11.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_tests pytest