summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-18 09:51:05 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-18 10:19:06 +0200
commit7682e30474e0c1b1141b08d47575c4ab84db1d87 (patch)
treeb28f2b3203ce77f511381d0e3afe82d3c4b20a8c /dev-python/authres
parentdev-python/authheaders: Bump to 0.15.0 (diff)
downloadgentoo-7682e30474e0c1b1141b08d47575c4ab84db1d87.tar.gz
gentoo-7682e30474e0c1b1141b08d47575c4ab84db1d87.tar.bz2
gentoo-7682e30474e0c1b1141b08d47575c4ab84db1d87.zip
dev-python/authres: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/authres')
-rw-r--r--dev-python/authres/authres-1.2.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/authres/authres-1.2.0-r1.ebuild b/dev-python/authres/authres-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..274f78a74a92
--- /dev/null
+++ b/dev-python/authres/authres-1.2.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Parse and generate Authentication-Results headers"
+HOMEPAGE="
+ https://launchpad.net/authentication-results-python/
+ https://pypi.org/project/authres/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+SLOT="0"
+
+python_test() {
+ "${EPYTHON}" -m doctest -v authres/tests ||
+ die "Tests fail with ${EPYTHON}"
+}