summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/asset
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/asset')
-rw-r--r--dev-python/asset/Manifest1
-rw-r--r--dev-python/asset/asset-0.6.1-r1.ebuild41
-rw-r--r--dev-python/asset/files/asset-0.6.1-broken-test.patch24
-rw-r--r--dev-python/asset/metadata.xml12
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/asset/Manifest b/dev-python/asset/Manifest
new file mode 100644
index 000000000000..60a6ce5ec2a6
--- /dev/null
+++ b/dev-python/asset/Manifest
@@ -0,0 +1 @@
+DIST asset-0.6.1.tar.gz 20613 SHA256 071fcbf93b03d791b4e301c1459dc6bd1779407f9c0326fa136f03449c4bb4c4 SHA512 6fa20888220e83a0a122b8ab63e531551724c64476c3fce8f47f784731710fa3328fa4ac3855bde5fb4caed47274f0492e14df438cf7857c0e5437f33217b672 WHIRLPOOL ca266bb9969e7b4f1b8a7940928ac3dac169374b5c7e44af091f112dcee975ed8d699bcf864645c2122ca3b503e54357a25884d7d2f97c32ae6ad67d67354fc9
diff --git a/dev-python/asset/asset-0.6.1-r1.ebuild b/dev-python/asset/asset-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..c90e15b43b28
--- /dev/null
+++ b/dev-python/asset/asset-0.6.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A package resource and symbol loading helper library"
+HOMEPAGE="https://pypi.python.org/pypi/asset http://github.com/metagriffin/asset"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/globre-0.0.5[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pxml-0.2.11[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/${P}-broken-test.patch )
+
+python_prepare_all() {
+ sed \
+ -e '/distribute/d' \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbose || die
+}
diff --git a/dev-python/asset/files/asset-0.6.1-broken-test.patch b/dev-python/asset/files/asset-0.6.1-broken-test.patch
new file mode 100644
index 000000000000..1a59f3f5c2bf
--- /dev/null
+++ b/dev-python/asset/files/asset-0.6.1-broken-test.patch
@@ -0,0 +1,24 @@
+ asset/test.py | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/asset/test.py b/asset/test.py
+index 992e5fc..c8aab32 100644
+--- a/asset/test.py
++++ b/asset/test.py
+@@ -24,6 +24,8 @@ import pxml
+ import xml.etree.ElementTree as ET
+ import six
+
++from nose.plugins.skip import SkipTest
++
+ import asset
+
+ #------------------------------------------------------------------------------
+@@ -107,6 +109,7 @@ line-2</node>
+ ])
+
+ #----------------------------------------------------------------------------
++ @SkipTest
+ def test_filename(self):
+ # NOTE: this requires that `pxml` was installed as a zipped egg, and
+ # `globre` as an UNzipped egg, i.e.:
diff --git a/dev-python/asset/metadata.xml b/dev-python/asset/metadata.xml
new file mode 100644
index 000000000000..375f7e43a16a
--- /dev/null
+++ b/dev-python/asset/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">asset</remote-id>
+ </upstream>
+</pkgmetadata>