summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-10 07:31:24 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-10 07:31:24 +0200
commitf2346118ae1ba9b31d0dc75dfa2c160ee4c12909 (patch)
treef2203322df90c3fb13afe3c5c623ff246b826ae7 /dev-python/asgiref
parentdev-python/boto3: Bump to 1.15.16 (diff)
downloadgentoo-f2346118ae1ba9b31d0dc75dfa2c160ee4c12909.tar.gz
gentoo-f2346118ae1ba9b31d0dc75dfa2c160ee4c12909.tar.bz2
gentoo-f2346118ae1ba9b31d0dc75dfa2c160ee4c12909.zip
dev-python/asgiref: Bump to 3.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asgiref')
-rw-r--r--dev-python/asgiref/Manifest1
-rw-r--r--dev-python/asgiref/asgiref-3.3.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/asgiref/Manifest b/dev-python/asgiref/Manifest
index 81cbf56ee067..60328e9da03e 100644
--- a/dev-python/asgiref/Manifest
+++ b/dev-python/asgiref/Manifest
@@ -1 +1,2 @@
DIST asgiref-3.2.10.tar.gz 25669 BLAKE2B 2cd0328054b218ae8abf840f85c7da6d9183dd5a52cef78176756020eb1f565fded9717fced3bc7fc4b85f9f1ff34b46ea95231b74afec0cbcc5000f9468c28b SHA512 8688d71103dfe569978712481161a88cce9aa6587eacbf29ea42d585817c813625360724d1d561d12456a6580647f9d4a098f194bd780f3c9f7e52a1e0aa8c88
+DIST asgiref-3.3.0.tar.gz 26945 BLAKE2B bdb1154175f95fc068fd1841a69ec9c5e782c212d9649aef0b9ca7592987f88d23311149f573febd76e5ab6fea4e6087a8c5e6e9e2edb4dab37d34ff3d180845 SHA512 fbb66af8f0e2bbeed31ae6ac358f045c0eef6cdeec6edbaf358f7551ff24e69233cfbc898b60ac9d16d747a9fb7e10a8b203065602140c025b2ae7d4d7229def
diff --git a/dev-python/asgiref/asgiref-3.3.0.ebuild b/dev-python/asgiref/asgiref-3.3.0.ebuild
new file mode 100644
index 000000000000..2a8bf860303e
--- /dev/null
+++ b/dev-python/asgiref/asgiref-3.3.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="ASGI utilities (successor to WSGI)"
+HOMEPAGE="
+ https://asgi.readthedocs.io/en/latest/
+ https://github.com/django/asgiref/
+ https://pypi.org/project/asgiref/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/pytest-asyncio[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest