summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-10 04:26:01 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-10 04:26:01 +0100
commit53afd531a1884c7b1659a85a5097c87ad5ab0eb9 (patch)
tree1a095b3e44239e6d5ede109d9c12574fa755da1b /dev-python/apprise
parentdev-python/apprise: Remove old (diff)
downloadgentoo-53afd531a1884c7b1659a85a5097c87ad5ab0eb9.tar.gz
gentoo-53afd531a1884c7b1659a85a5097c87ad5ab0eb9.tar.bz2
gentoo-53afd531a1884c7b1659a85a5097c87ad5ab0eb9.zip
dev-python/apprise: Bump to 1.7.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apprise')
-rw-r--r--dev-python/apprise/Manifest1
-rw-r--r--dev-python/apprise/apprise-1.7.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/apprise/Manifest b/dev-python/apprise/Manifest
index 30f218b2df2d..1a8865e4d16f 100644
--- a/dev-python/apprise/Manifest
+++ b/dev-python/apprise/Manifest
@@ -1 +1,2 @@
DIST apprise-1.7.3.tar.gz 1644531 BLAKE2B ea825be56ab037df25b46515e1c2a8dd6da0b202cd117fffd6138bbda183d83ef0586df90198a47de9030bb2e7b2f7c27eea24b30b5df04eee6d557a7f61a910 SHA512 1f5dad1f9b4c89c40a28a889ff03fcae104101678e3fe80063333be8508d17b5cea45dcc8af8fcafea36e5e6455f42659b7ff92be3cb0e4545468ab30a49460c
+DIST apprise-1.7.4.tar.gz 1648673 BLAKE2B 33c91a63e3d0e730dcfe2b99433cd97e16ff9635e9ff717e9c4f7b708e6536185265e591ff419a785044877cadd4793f2df73fe9420ffed65838fb16654810f8 SHA512 5e3ab2136f1bdbd9d769fb3e3c5a5c899834b7ffb6ba57f3601079d516e31bed9d988b76745c251fff6df91f1fcd186d23a0878165ad73b811f76a8118278a64
diff --git a/dev-python/apprise/apprise-1.7.4.ebuild b/dev-python/apprise/apprise-1.7.4.ebuild
new file mode 100644
index 000000000000..a85837c32c40
--- /dev/null
+++ b/dev-python/apprise/apprise-1.7.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Push Notifications that work with just about every platform"
+HOMEPAGE="
+ https://pypi.org/project/apprise/
+ https://github.com/caronc/apprise/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="+dbus mqtt"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ mqtt? ( dev-python/paho-mqtt[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest