summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-07 21:52:29 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-07 22:11:45 +0300
commitd7090b5d5fd4e5ae6f7634f5c796cb6fab82e2e1 (patch)
tree8388ea7ae117a2f228395a889aeba89a585d6b00 /dev-python/ansi2html
parentdev-python/jsonschema: add 4.6.2 (diff)
downloadgentoo-d7090b5d5fd4e5ae6f7634f5c796cb6fab82e2e1.tar.gz
gentoo-d7090b5d5fd4e5ae6f7634f5c796cb6fab82e2e1.tar.bz2
gentoo-d7090b5d5fd4e5ae6f7634f5c796cb6fab82e2e1.zip
dev-python/ansi2html: add 1.8.0, EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/ansi2html')
-rw-r--r--dev-python/ansi2html/Manifest1
-rw-r--r--dev-python/ansi2html/ansi2html-1.8.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/ansi2html/Manifest b/dev-python/ansi2html/Manifest
index ae7a56d67155..005196d5adea 100644
--- a/dev-python/ansi2html/Manifest
+++ b/dev-python/ansi2html/Manifest
@@ -1 +1,2 @@
DIST ansi2html-1.7.0.tar.gz 42189 BLAKE2B 91c7409b4f8b7503e719489b18e9d7267d80c5259b7481f127cb8d1e6429649249b0832746285efc3e8a4f90ca8f21b872b002634d47a4a54ddfdcc74df0f576 SHA512 bcae0de9874899bd8440853b8279f3b2c4ed46e24bf807221ddc9d1bfa39647e2efd178aefc2fd39bad27b53890270b6ff7c150a0b8e74581b8323ef7a16c977
+DIST ansi2html-1.8.0.tar.gz 44146 BLAKE2B 66672927a64ad38dce0b0819fabc3778f6aba82d176e992630a8db076988a21af8dd445306b8bb580f1539b35044b95de749d6bfb65c27f9b431e4cb6bd562c7 SHA512 cbdda41f206ced5b19761a1ff9747acc6cadca3a5a2f58c97c6073db7d517e59fea7601bba28a8e7e105f3c0c9c4d78ca4f242100cbded6c8a9ca2d598de0ab4
diff --git a/dev-python/ansi2html/ansi2html-1.8.0.ebuild b/dev-python/ansi2html/ansi2html-1.8.0.ebuild
new file mode 100644
index 000000000000..9b52578c0779
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="https://pypi.org/project/ansi2html/
+ https://github.com/pycontribs/ansi2html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ doc? (
+ app-text/asciidoc
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && doman man/${PN}.1
+ distutils-r1_python_install_all
+}
+
+src_compile() {
+ # Upstream https://github.com/pycontribs/ansi2html/issues/124
+ use doc && emake _MANUAL_VERSION="${PV}" man/ansi2html.1
+ distutils-r1_src_compile
+}