summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-11 10:19:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-11 10:59:13 +0100
commit55d385e737cab0bb3210cc635fa388d08540e3e9 (patch)
tree2c014f85a96157302e291d14b354db626947c38c /dev-python/aioresponses
parentdev-python/sphinx-issues: Bump to 3.0.0 (diff)
downloadgentoo-55d385e737cab0bb3210cc635fa388d08540e3e9.tar.gz
gentoo-55d385e737cab0bb3210cc635fa388d08540e3e9.tar.bz2
gentoo-55d385e737cab0bb3210cc635fa388d08540e3e9.zip
dev-python/aioresponses: Bump to 0.7.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aioresponses')
-rw-r--r--dev-python/aioresponses/Manifest1
-rw-r--r--dev-python/aioresponses/aioresponses-0.7.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/aioresponses/Manifest b/dev-python/aioresponses/Manifest
index 542a81edf4e8..32fe2b0d082a 100644
--- a/dev-python/aioresponses/Manifest
+++ b/dev-python/aioresponses/Manifest
@@ -1 +1,2 @@
DIST aioresponses-0.7.2.tar.gz 28135 BLAKE2B 300d06ed43ad81d61fe9cab4002b9e9bb062a48aabed8aed21e3a8e26d8e153546ed079e6dda6ef26c6df2e843663ed9e02b2855ac71e011b873da926923a72d SHA512 847c687990c38733c714cfd7b4f268406392aeea6764f084dae25f43246b7b5731f149067fb921864b1b22c9e7b2ca66254ff311d726333d0b23a5566ab18029
+DIST aioresponses-0.7.3.tar.gz 28895 BLAKE2B e948e25daef231b7984609ca475cde9ce026880953b395ebf1d5619fc951338614d1f56332c54467706f66275bc8aa1be9f04d3503295388f9dd4a213316d7c8 SHA512 9e2bdbf4fe5089928de9a7ddd54931d70ea137fbaba2bd22b32d248c9282f70d551a3aa2de270342bdf0c1acd0973b377f503d1194156aa545109ef3458278b5
diff --git a/dev-python/aioresponses/aioresponses-0.7.3.ebuild b/dev-python/aioresponses/aioresponses-0.7.3.ebuild
new file mode 100644
index 000000000000..4dc31d4d5b5d
--- /dev/null
+++ b/dev-python/aioresponses/aioresponses-0.7.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helper to mock/fake web requests in Python's aiohttp package"
+HOMEPAGE="https://github.com/pnuckowski/aioresponses"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/aiohttp[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # These tests require Internet access
+ tests/test_aioresponses.py::AIOResponsesTestCase::test_address_as_instance_of_url_combined_with_pass_through
+ tests/test_aioresponses.py::AIOResponsesTestCase::test_pass_through_with_origin_params
+ )
+ epytest ${deselect[@]/#/--deselect }
+}