summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/Coffin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/Coffin')
-rw-r--r--dev-python/Coffin/Coffin-0.3.8.ebuild27
-rw-r--r--dev-python/Coffin/Coffin-2.0.1.ebuild28
-rw-r--r--dev-python/Coffin/Manifest2
-rw-r--r--dev-python/Coffin/metadata.xml9
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/Coffin/Coffin-0.3.8.ebuild b/dev-python/Coffin/Coffin-0.3.8.ebuild
new file mode 100644
index 000000000000..cfee55e95ed5
--- /dev/null
+++ b/dev-python/Coffin/Coffin-0.3.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Jinja2 adapter for Django"
+HOMEPAGE="http://github.com/coffin/coffin"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_prepare_all() {
+ # Req'd to avoid file collisions
+ sed -e s":find_packages():find_packages(exclude=['tests']):" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/Coffin/Coffin-2.0.1.ebuild b/dev-python/Coffin/Coffin-2.0.1.ebuild
new file mode 100644
index 000000000000..f05201ec9f93
--- /dev/null
+++ b/dev-python/Coffin/Coffin-2.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Jinja2 adapter for Django"
+HOMEPAGE="http://github.com/coffin/coffin"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_prepare_all() {
+ # Req'd to avoid file collisions
+ sed -e s":find_packages():find_packages(exclude=['tests']):" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+# Tests attempt to import an abandonned module
diff --git a/dev-python/Coffin/Manifest b/dev-python/Coffin/Manifest
new file mode 100644
index 000000000000..0d48379a8665
--- /dev/null
+++ b/dev-python/Coffin/Manifest
@@ -0,0 +1,2 @@
+DIST Coffin-0.3.8.tar.gz 35269 SHA256 be3e804ea1c740d8f09c0f811253eee4c6aeeb993455521cac6e95e1e4d6151b SHA512 e3e0b9855e14b7fc57cd164aa3ba50f84847eb8a324d4ceaf52513224d235889407c061d542a894b82d6cdc96fc378fd44856d46f471333017d7a6ac6427c7d3 WHIRLPOOL c8105e5900e0f07a461689ca0c7295bb483991ec86466f4e72b8e837631fe6135a5db9192598d1f763bbfff773a06d5b611e391620a9ac76f3313f475802d978
+DIST Coffin-2.0.1.tar.gz 9858 SHA256 b1cfb44b1ef7daabc7c607a937f85e4b89b63bd9536ee3b817461747a476a65c SHA512 e618c74a91f84e7f41411c8e34b2c97fad1a59bc5124f0f5b3439abf1b0c2972d5f59d4b71f49393e843cd588ec143c08d659e90d2cfd006d55b5244b5727ccc WHIRLPOOL a1c745eca498ac5e7877c0ce20433d22c647d9e419b5269eb1a167d9ab478c068acfd6d2d59f485e8cb2f2fe7b440aa84c34ccefdc7595fb43a9d320e08d12cd
diff --git a/dev-python/Coffin/metadata.xml b/dev-python/Coffin/metadata.xml
new file mode 100644
index 000000000000..69bd5d0783f4
--- /dev/null
+++ b/dev-python/Coffin/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Coffin</remote-id>
+ <remote-id type="github">coffin/coffin</remote-id>
+ </upstream>
+</pkgmetadata>