summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-09-15 13:11:12 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-19 20:48:18 +0300
commitcc2201632a3cb96f93a591c51e14df96329c7b40 (patch)
treefa894170419d5d31b19e0fb4969a5b1690916b5f /dev-php
parentdev-php/pecl-translit: fix VariableShadowed (diff)
downloadgentoo-cc2201632a3cb96f93a591c51e14df96329c7b40.tar.gz
gentoo-cc2201632a3cb96f93a591c51e14df96329c7b40.tar.bz2
gentoo-cc2201632a3cb96f93a591c51e14df96329c7b40.zip
dev-php/pecl-eio: fix VariableShadowed
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-eio/pecl-eio-3.0.0_rc2.ebuild11
-rw-r--r--dev-php/pecl-eio/pecl-eio-3.0.0_rc4.ebuild11
-rw-r--r--dev-php/pecl-eio/pecl-eio-3.1.0_rc1.ebuild11
3 files changed, 15 insertions, 18 deletions
diff --git a/dev-php/pecl-eio/pecl-eio-3.0.0_rc2.ebuild b/dev-php/pecl-eio/pecl-eio-3.0.0_rc2.ebuild
index 170f4580cb4b..b7ea9d1d2ba3 100644
--- a/dev-php/pecl-eio/pecl-eio-3.0.0_rc2.ebuild
+++ b/dev-php/pecl-eio/pecl-eio-3.0.0_rc2.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
MY_PN="${PN/pecl-}"
MY_PV="${PV/_rc/RC}"
MY_P="${MY_PN}-${MY_PV}"
@@ -15,16 +16,14 @@ DOCS=( README.md )
USE_PHP="php8-0"
inherit php-ext-pecl-r3
-KEYWORDS="~amd64 ~x86"
-LICENSE="PHP-3.01"
-
DESCRIPTION="PHP wrapper for libeio library"
-LICENSE="PHP-3"
+S="${PHP_EXT_S}"
+
+LICENSE="PHP-3.01"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="debug"
-S="${PHP_EXT_S}"
-
src_configure() {
local PHP_EXT_ECONF_ARGS=("--with-eio" "$(use_enable debug eio-debug)" )
php-ext-source-r3_src_configure
diff --git a/dev-php/pecl-eio/pecl-eio-3.0.0_rc4.ebuild b/dev-php/pecl-eio/pecl-eio-3.0.0_rc4.ebuild
index 47a57328a455..09c39fede5e8 100644
--- a/dev-php/pecl-eio/pecl-eio-3.0.0_rc4.ebuild
+++ b/dev-php/pecl-eio/pecl-eio-3.0.0_rc4.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
MY_PN="${PN/pecl-}"
MY_PV="${PV/_rc/RC}"
MY_P="${MY_PN}-${MY_PV}"
@@ -15,16 +16,14 @@ DOCS=( README.md )
USE_PHP="php8-0 php8-1"
inherit php-ext-pecl-r3
-KEYWORDS="~amd64 ~x86"
-LICENSE="PHP-3.01"
-
DESCRIPTION="PHP wrapper for libeio library"
-LICENSE="PHP-3"
+S="${PHP_EXT_S}"
+
+LICENSE="PHP-3.01"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="debug"
-S="${PHP_EXT_S}"
-
src_configure() {
local PHP_EXT_ECONF_ARGS=("--with-eio" "$(use_enable debug eio-debug)" )
php-ext-source-r3_src_configure
diff --git a/dev-php/pecl-eio/pecl-eio-3.1.0_rc1.ebuild b/dev-php/pecl-eio/pecl-eio-3.1.0_rc1.ebuild
index 47a57328a455..09c39fede5e8 100644
--- a/dev-php/pecl-eio/pecl-eio-3.1.0_rc1.ebuild
+++ b/dev-php/pecl-eio/pecl-eio-3.1.0_rc1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
MY_PN="${PN/pecl-}"
MY_PV="${PV/_rc/RC}"
MY_P="${MY_PN}-${MY_PV}"
@@ -15,16 +16,14 @@ DOCS=( README.md )
USE_PHP="php8-0 php8-1"
inherit php-ext-pecl-r3
-KEYWORDS="~amd64 ~x86"
-LICENSE="PHP-3.01"
-
DESCRIPTION="PHP wrapper for libeio library"
-LICENSE="PHP-3"
+S="${PHP_EXT_S}"
+
+LICENSE="PHP-3.01"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="debug"
-S="${PHP_EXT_S}"
-
src_configure() {
local PHP_EXT_ECONF_ARGS=("--with-eio" "$(use_enable debug eio-debug)" )
php-ext-source-r3_src_configure