summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2023-02-20 15:39:45 -0500
committerBrian Evans <grknight@gentoo.org>2023-02-20 15:40:23 -0500
commitc53a711a505f1387ff0aae51af2d42f599ba2ac9 (patch)
treea1b98ee99ebf4278c14ba458d60952f5ba74ee7b /dev-php
parentdev-php/scrypt: Version bump for 2.0.0 and update live (diff)
downloadgentoo-c53a711a505f1387ff0aae51af2d42f599ba2ac9.tar.gz
gentoo-c53a711a505f1387ff0aae51af2d42f599ba2ac9.tar.bz2
gentoo-c53a711a505f1387ff0aae51af2d42f599ba2ac9.zip
dev-php/scrypt: Drop old
Non-maintainer commit Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/scrypt/Manifest1
-rw-r--r--dev-php/scrypt/files/scrypt-1.4.2-php8-0.patch49
-rw-r--r--dev-php/scrypt/scrypt-1.4.2.ebuild20
3 files changed, 0 insertions, 70 deletions
diff --git a/dev-php/scrypt/Manifest b/dev-php/scrypt/Manifest
index 02e75d2c03b0..00e5ed387f21 100644
--- a/dev-php/scrypt/Manifest
+++ b/dev-php/scrypt/Manifest
@@ -1,2 +1 @@
-DIST scrypt-1.4.2.tgz 21585 BLAKE2B 6297b15aac8470eedc619c498badc4e453476a390cab0cfe7fabef00012131ff9e363834b9423a566dba603ea2a4351eee416419cc1e6c1245a9aba54d63a5ab SHA512 34a87e63250dcfb21b3d36f90a4e5f4bac9f0623917ceb0d613d49112ce0e13df9a93fb0730fb797be6337d023dc490fb881902b5492309fe8bf3e6fd5e685a0
DIST scrypt-2.0.0.tgz 23229 BLAKE2B 71a40869004cbcb3fb6b303e1d59c0687b9817b89b38ebedc0001a732f4d4fba134ba124b09a6b4970da9892654631b41d0ce8e79d60eaccf788344972cb0760 SHA512 88b559f112f768eb1b61652ee5a6a75edbfd6133aca39c0d740dd083e3d2f718232a607a05a306cd40faeb4cab48f98de04f0799011d86543385583a99fb508f
diff --git a/dev-php/scrypt/files/scrypt-1.4.2-php8-0.patch b/dev-php/scrypt/files/scrypt-1.4.2-php8-0.patch
deleted file mode 100644
index a5e1ea665897..000000000000
--- a/dev-php/scrypt/files/scrypt-1.4.2-php8-0.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 5010f9fa0743518d149d994728ca930503adde1e Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 22 Sep 2020 14:55:32 +0200
-Subject: [PATCH] trivial fix for PHP 8
-
----
- crypto/crypto_scrypt-sse.c | 1 +
- php_scrypt.h | 5 +++++
- php_scrypt_utils.c | 1 +
- 3 files changed, 7 insertions(+)
-
-diff --git a/crypto/crypto_scrypt-sse.c b/crypto/crypto_scrypt-sse.c
-index a52ce81..709a04f 100644
---- a/crypto/crypto_scrypt-sse.c
-+++ b/crypto/crypto_scrypt-sse.c
-@@ -44,6 +44,7 @@
- #include "sysendian.h"
-
- #include "crypto_scrypt.h"
-+#include "php_scrypt.h"
-
- static void blkcpy(void *, void *, size_t);
- static void blkxor(void *, void *, size_t);
-diff --git a/php_scrypt.h b/php_scrypt.h
-index a1117c8..6cc1c4c 100644
---- a/php_scrypt.h
-+++ b/php_scrypt.h
-@@ -35,4 +35,9 @@ PHP_FUNCTION(scrypt_pickparams);
- extern zend_module_entry scrypt_module_entry;
- #define phpext_scrypt_ptr &scrypt_module_entry
-
-+#ifndef TSRMLS_CC
-+#define TSRMLS_CC
-+#define TSRMLS_FETCH()
-+#endif
-+
- #endif
-diff --git a/php_scrypt_utils.c b/php_scrypt_utils.c
-index 797e2c7..34fe347 100644
---- a/php_scrypt_utils.c
-+++ b/php_scrypt_utils.c
-@@ -25,6 +25,7 @@
- */
-
- #include "php_scrypt_utils.h"
-+#include "php_scrypt.h"
-
- /*
- * Casts a long into a uint64_t.
diff --git a/dev-php/scrypt/scrypt-1.4.2.ebuild b/dev-php/scrypt/scrypt-1.4.2.ebuild
deleted file mode 100644
index 026a54355943..000000000000
--- a/dev-php/scrypt/scrypt-1.4.2.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PHP_EXT_ECONF_ARGS="--enable-scrypt"
-USE_PHP="php7-3 php7-4 php8-0"
-
-inherit php-ext-pecl-r3
-
-DESCRIPTION="A PHP wrapper fo the scrypt hashing algorithm"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-util/re2c"
-
-PATCHES=( "${FILESDIR}"/"${P}"-php8-0.patch )