summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-09-27 14:03:01 -0400
committerMichael Orlitzky <mjo@gentoo.org>2015-09-27 14:03:01 -0400
commitd091720edf4b7dcb2106d6cf064b680eb3ac82e4 (patch)
treedc72832fb1ef410812a4dc21ee67a0720210f809 /dev-php/igbinary
parentdev-php/igbinary: remove unused files/zts-fix.patch. (diff)
downloadgentoo-d091720edf4b7dcb2106d6cf064b680eb3ac82e4.tar.gz
gentoo-d091720edf4b7dcb2106d6cf064b680eb3ac82e4.tar.bz2
gentoo-d091720edf4b7dcb2106d6cf064b680eb3ac82e4.zip
dev-php/igbinary: revision bump to fix DOCS.
The existing DOCS string contained a nonexistent file. It has been updated with the correct values, and a little cleanup was performed at the same time. Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-php/igbinary')
-rw-r--r--dev-php/igbinary/Manifest1
-rw-r--r--dev-php/igbinary/igbinary-1.2.1-r1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/igbinary/Manifest b/dev-php/igbinary/Manifest
index 8a6daf1a64ce..999547993181 100644
--- a/dev-php/igbinary/Manifest
+++ b/dev-php/igbinary/Manifest
@@ -1 +1,2 @@
+DIST igbinary-1.2.1-r1.tar.gz 143092 SHA256 f71a2e085669ed915740b29f55b6a81e30bae52215d041938afb9212e6bafc27 SHA512 5e69831606cfe47db2ae2b2200bd8bcfce42db32599a2a58cf23238d88896a2ef79baf16e78b3aaefb8725f8fdd7b815470e2d314ba14ea05f33be547da31777 WHIRLPOOL f7eb5d28b536bd1d2b0565f3e8541cbdb39edd2f5130bd041f0d75cc8218edeaa8719ebaea4d8ddf372172df9863d9d72a12dd8fc09c3653418b49e26d0e2f61
DIST igbinary-1.2.1.tar.gz 143092 SHA256 f71a2e085669ed915740b29f55b6a81e30bae52215d041938afb9212e6bafc27 SHA512 5e69831606cfe47db2ae2b2200bd8bcfce42db32599a2a58cf23238d88896a2ef79baf16e78b3aaefb8725f8fdd7b815470e2d314ba14ea05f33be547da31777 WHIRLPOOL f7eb5d28b536bd1d2b0565f3e8541cbdb39edd2f5130bd041f0d75cc8218edeaa8719ebaea4d8ddf372172df9863d9d72a12dd8fc09c3653418b49e26d0e2f61
diff --git a/dev-php/igbinary/igbinary-1.2.1-r1.ebuild b/dev-php/igbinary/igbinary-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..258ea58113e9
--- /dev/null
+++ b/dev-php/igbinary/igbinary-1.2.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PHP_EXT_NAME="${PN}"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="ChangeLog NEWS README.md"
+
+USE_PHP="php5-4 php5-5 php5-6"
+
+inherit php-ext-source-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A fast drop-in replacement for the standard PHP serialize"
+HOMEPAGE="https://github.com/${PN}/${PN}"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${PF}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ my_conf="--enable-${PN}"
+ php-ext-source-r2_src_configure
+}
+
+src_test() {
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ NO_INTERACTION="yes" emake test \
+ || die "test suite failed for slot ${slot}"
+ done
+}