summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-05-02 17:28:25 +1100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-05-02 17:28:51 +1100
commit434b3a28007e016cf173ed5726f92e9697017355 (patch)
treef51b79650a84147512cf36a284b3dc58af11acd8 /dev-perl/Statistics-Descriptive
parentdev-perl/Test-Inter: add 1.110.0 (diff)
downloadgentoo-434b3a28007e016cf173ed5726f92e9697017355.tar.gz
gentoo-434b3a28007e016cf173ed5726f92e9697017355.tar.bz2
gentoo-434b3a28007e016cf173ed5726f92e9697017355.zip
dev-perl/Statistics-Descriptive: add 3.80.100
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Statistics-Descriptive')
-rw-r--r--dev-perl/Statistics-Descriptive/Manifest1
-rw-r--r--dev-perl/Statistics-Descriptive/Statistics-Descriptive-3.80.100.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Statistics-Descriptive/Manifest b/dev-perl/Statistics-Descriptive/Manifest
index d3da521501d6..1b331fb80480 100644
--- a/dev-perl/Statistics-Descriptive/Manifest
+++ b/dev-perl/Statistics-Descriptive/Manifest
@@ -1 +1,2 @@
DIST Statistics-Descriptive-3.0800.tar.gz 53611 BLAKE2B efefcffbb83b153d7211756b30e5e00447f3aaec768f4849601f3c5b83c4ca60cdb56f15c5ff95f2fff23045764fef31e813b961a8e886506da1d71983ae6f8d SHA512 691a99aca4214149d14c770d71b5d97eaefa2690698b0234b11ed33d7bdbc21e9b478941bb8fa46886ea3362f432eb744a3a3b3607f3d3fe189c4256884efdec
+DIST Statistics-Descriptive-3.0801.tar.gz 54174 BLAKE2B edb1e8e8a693f8c31e7df5336a0683f696772fed68dec0a6ade50c50be026e51534ddd44748a0b71eeadf69648a19bb1ae6d1524be087f9d9d5ca00ece6995f0 SHA512 e5901ed4f53807a53779113ad9288549dcf06618d2a81009f388edce0ead9f1178ce63eea07c0a427a3f00b6216f6e211cc2ca9b1c5fa91c82e4994343a33f35
diff --git a/dev-perl/Statistics-Descriptive/Statistics-Descriptive-3.80.100.ebuild b/dev-perl/Statistics-Descriptive/Statistics-Descriptive-3.80.100.ebuild
new file mode 100644
index 000000000000..fd6cd7e3b44d
--- /dev/null
+++ b/dev-perl/Statistics-Descriptive/Statistics-Descriptive-3.80.100.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=3.0801
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="Module of basic descriptive statistical functions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/List-MoreUtils
+ virtual/perl-Scalar-List-Utils
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.280.0
+ test? ( virtual/perl-Test-Simple )
+"
+
+mydoc="UserSurvey.txt"
+
+src_test() {
+ perl_rm_files "t/pod-coverage.t" "t/pod.t" "t/cpan-changes.t" "t/style-trailing-space.t"
+ perl-module_src_test
+}