summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2019-01-10 16:15:12 +1300
committerKent Fredric <kentnl@gentoo.org>2019-01-10 16:15:20 +1300
commit98c7d60eacb064cd8285eeccfd2a74af470c7dbc (patch)
treed149e61b8b103a356b31c8c9b6624a60dab5fc94 /dev-perl/Net-SSLeay
parentvirtual/perl-Locale-Maketext: Keyword ~x86-fbsd (diff)
downloadgentoo-98c7d60eacb064cd8285eeccfd2a74af470c7dbc.tar.gz
gentoo-98c7d60eacb064cd8285eeccfd2a74af470c7dbc.tar.bz2
gentoo-98c7d60eacb064cd8285eeccfd2a74af470c7dbc.zip
dev-perl/Net-SSLeay: Bump to version 1.850.0
- Simplify file removal - Remove 2 tests that break under FEATURES="network-sandbox" Upstream: - Fix problem exporting OPENSSL_NO_NEXTPROTONEG (not available on libressl) - Add SSL_set_default_passwd_cb* w/OpenSSL 1.1.0f+ - Add new functions for SSL_CTX_new - Add functions added in OpenSSL 1.1.0 - Add SSL_use_certificate_chain_file - Fix libressl version detection - Fix OCSP handling memleak - Add new functions for certificate verification - Add X509_STORE_CTX_new and X509_verify_cert - SSL_OCSP_response_verify now clears error queue when OCSP_basic_verify fails but intermediate certificate succeeds - Fix test failure when Test::Exception not installed - Fix t/local/33_x509_create_cert.t on various OpenSSLs Bug: https://rt.cpan.org/Ticket/Display.html?id=128207 Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Net-SSLeay')
-rw-r--r--dev-perl/Net-SSLeay/Manifest1
-rw-r--r--dev-perl/Net-SSLeay/Net-SSLeay-1.850.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-perl/Net-SSLeay/Manifest b/dev-perl/Net-SSLeay/Manifest
index 45ff273e4567..4337772143ce 100644
--- a/dev-perl/Net-SSLeay/Manifest
+++ b/dev-perl/Net-SSLeay/Manifest
@@ -1 +1,2 @@
DIST Net-SSLeay-1.82.tar.gz 399194 BLAKE2B 0c8aeb3085b102b71284266904ee88a8558070644aaa6dd0c5f78db0bfccb0e7456c8ba62a549d7ab245a02ddc7e856bc326d503f63268ee0761290e41b97e4d SHA512 758c41f4916a55b5085167e5c6a2732a5ee70dbeb8f42e791cd957957ba4a59f724c072d3fa50a6b42ae3b22cf3ecb8738c3f8963990a7030117b73c2dcc0716
+DIST Net-SSLeay-1.85.tar.gz 418349 BLAKE2B 0f639145e5be9406264cc7ef6240a30e0d62e631bfe29b8d1cbc85ab3bf721e8d344a8472faaa87816a5d148cedd7f13faeec925d0632fc1b75ecd1c5c44f6d1 SHA512 74e0f2f56b707f1ff845c78c1fa7ce26a71b8f943bb99e994d4e065d1f42259fe4cd1a6a17d333459727534158f9541f116dbc8515122380807d9450b0faa26b
diff --git a/dev-perl/Net-SSLeay/Net-SSLeay-1.850.0.ebuild b/dev-perl/Net-SSLeay/Net-SSLeay-1.850.0.ebuild
new file mode 100644
index 000000000000..dd754787ef04
--- /dev/null
+++ b/dev-perl/Net-SSLeay/Net-SSLeay-1.850.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MIKEM
+DIST_VERSION=1.85
+DIST_EXAMPLES=("examples/*")
+inherit multilib perl-module
+
+DESCRIPTION="Perl extension for using OpenSSL"
+
+LICENSE="openssl"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="libressl test minimal examples"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ virtual/perl-MIME-Base64
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Warn
+ dev-perl/Test-NoWarnings
+ )
+ virtual/perl-Test-Simple
+ )
+"
+export OPTIMIZE="$CFLAGS"
+export OPENSSL_PREFIX=${EPREFIX}/usr
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.82-respect-cflags.patch"
+ "${FILESDIR}/${PN}-1.82-fix-libdir.patch"
+ "${FILESDIR}/${PN}-1.82-fix-network-tests.patch"
+)
+PERL_RM_FILES=(
+ # Hateful author tests
+ 't/local/01_pod.t'
+ 't/local/02_pod_coverage.t'
+ 't/local/kwalitee.t'
+ # Broken under FEATURES="network-sandbox"
+ # https://rt.cpan.org/Ticket/Display.html?id=128207
+ 't/local/06_tcpecho.t'
+ 't/local/07_sslecho.t'
+)
+
+src_configure() {
+ if use test && has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ export NETWORK_TESTS=yes
+ else
+ use test && einfo "Network tests will be skipped without DIST_TEST_OVERRIDE=~network"
+ export NETWORK_TESTS=no
+ fi
+ export LIBDIR=$(get_libdir)
+ perl-module_src_configure
+}