summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-01-06 13:02:58 +1300
committerKent Fredric <kentnl@gentoo.org>2017-01-06 13:50:21 +1300
commitfdd0a8c99901be198cf199808e6d20359d3ea324 (patch)
tree81e4941b805417e577440e8fc4643700d4bac866 /dev-perl/Mozilla-PublicSuffix
parentdev-python/moto: Revision bump existing fixing httpretty dep (diff)
downloadgentoo-fdd0a8c99901be198cf199808e6d20359d3ea324.tar.gz
gentoo-fdd0a8c99901be198cf199808e6d20359d3ea324.tar.bz2
gentoo-fdd0a8c99901be198cf199808e6d20359d3ea324.zip
dev-perl/Mozilla-PublicSuffix: Add w/ version 1.0.0
Required by new dev-perl/HTTP-CookieJar, required by newer version of dev-perl/BZ-Client Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-perl/Mozilla-PublicSuffix')
-rw-r--r--dev-perl/Mozilla-PublicSuffix/Manifest1
-rw-r--r--dev-perl/Mozilla-PublicSuffix/Mozilla-PublicSuffix-1.0.0.ebuild34
-rw-r--r--dev-perl/Mozilla-PublicSuffix/files/1.0.0-no-dynamic-update.patch90
-rw-r--r--dev-perl/Mozilla-PublicSuffix/metadata.xml12
4 files changed, 137 insertions, 0 deletions
diff --git a/dev-perl/Mozilla-PublicSuffix/Manifest b/dev-perl/Mozilla-PublicSuffix/Manifest
new file mode 100644
index 000000000000..e57d42ad9b15
--- /dev/null
+++ b/dev-perl/Mozilla-PublicSuffix/Manifest
@@ -0,0 +1 @@
+DIST Mozilla-PublicSuffix-v1.0.0.tar.gz 71669 SHA256 8185ca687ad1c51e18cb472831f80160d6432376a06a19f864d617147b003dee SHA512 79ed7256bccb33f1f428657bd60cccaf7be5d4793424337b94a812a41f46e90507b8c32b3aa8b381bf16d77f4a3f911301f757332e9144718efd2341996d9cc6 WHIRLPOOL 1cab25d4505601bcaab570873225b78f1996e0fbc95325c6cc1799efc956255f361c2e35669384f121d112e2ea88e4359167b0edd5930d81d0cb03d206972195
diff --git a/dev-perl/Mozilla-PublicSuffix/Mozilla-PublicSuffix-1.0.0.ebuild b/dev-perl/Mozilla-PublicSuffix/Mozilla-PublicSuffix-1.0.0.ebuild
new file mode 100644
index 000000000000..ed0d65c60edb
--- /dev/null
+++ b/dev-perl/Mozilla-PublicSuffix/Mozilla-PublicSuffix-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=RSIMOES
+DIST_VERSION="v${PV}"
+inherit perl-module
+
+DESCRIPTION="Get a domain name's public suffix via the Mozilla Public Suffix List"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-no-dynamic-update.patch"
+)
+RDEPEND="
+ virtual/perl-Exporter
+ dev-perl/URI
+"
+DEPEND="${RDEPEND}
+ virtual/perl-IO
+ >=dev-perl/Module-Build-0.280.0
+ test? (
+ virtual/perl-Test-Simple
+ virtual/perl-File-Spec
+ )
+"
+src_test() {
+ perl_rm_files t/author-* t/release-*
+ perl-module_src_test
+}
diff --git a/dev-perl/Mozilla-PublicSuffix/files/1.0.0-no-dynamic-update.patch b/dev-perl/Mozilla-PublicSuffix/files/1.0.0-no-dynamic-update.patch
new file mode 100644
index 000000000000..99c76a4dc754
--- /dev/null
+++ b/dev-perl/Mozilla-PublicSuffix/files/1.0.0-no-dynamic-update.patch
@@ -0,0 +1,90 @@
+From 7dcc6afa75d5318325856fdef0456f4ddf1672b1 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Fri, 6 Jan 2017 12:32:50 +1300
+Subject: [PATCH] Remove dynamic update code
+
+As this basically makes builds unreproducale anyway, and the download
+URI is invariant meaning we can't even approximate the same logic via
+SRC_URI without having frequently changing Manifests, but no change in
+URI.
+---
+ Build.PL | 26 --------------------------
+ META.yml | 2 --
+ 2 files changed, 28 deletions(-)
+
+diff --git a/Build.PL b/Build.PL
+index 7ef1ca0..1e7834d 100755
+--- a/Build.PL
++++ b/Build.PL
+@@ -5,11 +5,9 @@ use warnings FATAL => "all";
+ use utf8;
+ use open ":encoding(UTF-8)";
+ use Carp qw(croak);
+-use HTTP::Tiny;
+ use Module::Build;
+ use IO::File;
+ use Tie::File;
+-use URI;
+
+ my $builder = Module::Build->new(
+ dist_name => "Mozilla-PublicSuffix",
+@@ -28,11 +26,9 @@ my $builder = Module::Build->new(
+ 'perl' => '5.008'
+ },
+ 'configure_requires' => {
+- 'HTTP::Tiny' => '0',
+ 'IO::File' => '0',
+ 'Module::Build' => '0.28',
+ 'Tie::File' => '0',
+- 'URI' => '0',
+ 'perl' => '5.008'
+ },
+ 'requires' => {
+@@ -43,28 +39,6 @@ my $builder = Module::Build->new(
+ );
+
+ my $dat_file = "effective_tld_names.dat";
+-my $get_new_list = $builder->y_n(
+- "Check for a new version of the Public Suffix List?", "N"
+-);
+-if ($get_new_list) {
+- my $http = HTTP::Tiny->new( timeout => 6 );
+- my $list_uri = URI->new(
+- "http://mxr.mozilla.org/mozilla-central/source/netwerk/dns/$dat_file"
+- );
+- $list_uri->query_form({ raw => 1 });
+- my %options = (
+- headers => {
+- "If-Modified-Since" => "Fri, 17 May 2013 00:00:00 UTC"
+- }
+- );
+- my $response = $http->get($list_uri, \%options);
+- if ( $response->{status} == 200 ) {
+- IO::File->new($dat_file, "w")->print($response->{content});
+- }
+- elsif ( $response->{status} != 304 ) {
+- croak "Unable to download public suffix list.";
+- }
+-}
+
+ # Divide rules from list into sets:
+ my $rules = join " ", map {
+diff --git a/META.yml b/META.yml
+index b25bc9c..2697608 100644
+--- a/META.yml
++++ b/META.yml
+@@ -11,11 +11,9 @@ build_requires:
+ blib: '1.01'
+ perl: '5.008'
+ configure_requires:
+- HTTP::Tiny: '0'
+ IO::File: '0'
+ Module::Build: '0.28'
+ Tie::File: '0'
+- URI: '0'
+ perl: '5.008'
+ dynamic_config: 0
+ generated_by: 'Dist::Zilla version 6.006, CPAN::Meta::Converter version 2.150001'
+--
+2.11.0
+
diff --git a/dev-perl/Mozilla-PublicSuffix/metadata.xml b/dev-perl/Mozilla-PublicSuffix/metadata.xml
new file mode 100644
index 000000000000..ef5b9e9b4db5
--- /dev/null
+++ b/dev-perl/Mozilla-PublicSuffix/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Mozilla-PublicSuffix</remote-id>
+ <remote-id type="cpan-module">Mozilla::PublicSuffix</remote-id>
+ </upstream>
+</pkgmetadata>