summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-02-22 08:16:53 +1300
committerKent Fredric <kentfredric@gmail.com>2016-02-22 22:11:36 +1300
commit8ea0d8b64eb57cad46e46fa7e6de881bc6354757 (patch)
treec2bb5ce1914d49338e4512c5af2ae391753d936c /dev-perl/Lexical-Persistence/Lexical-Persistence-1.23.0.ebuild
parentdev-perl/LWPx-ParanoidAgent: Bump to version 1.100.0 (diff)
downloadgentoo-8ea0d8b64eb57cad46e46fa7e6de881bc6354757.tar.gz
gentoo-8ea0d8b64eb57cad46e46fa7e6de881bc6354757.tar.bz2
gentoo-8ea0d8b64eb57cad46e46fa7e6de881bc6354757.zip
dev-perl/Lexical-Persistence: Bump to version 1.23.0
- use EAPI6 - cleanup deps - Nuke stupid POD tests Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/Lexical-Persistence/Lexical-Persistence-1.23.0.ebuild')
-rw-r--r--dev-perl/Lexical-Persistence/Lexical-Persistence-1.23.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Lexical-Persistence/Lexical-Persistence-1.23.0.ebuild b/dev-perl/Lexical-Persistence/Lexical-Persistence-1.23.0.ebuild
new file mode 100644
index 000000000000..e67f1d058093
--- /dev/null
+++ b/dev-perl/Lexical-Persistence/Lexical-Persistence-1.23.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=RCAPUTO
+DIST_VERSION=1.023
+inherit perl-module
+
+DESCRIPTION="Bind lexicals to persistent data"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+# constant -> perl
+RDEPEND="
+ >=dev-perl/PadWalker-1.960.0
+ >=dev-perl/Devel-LexAlias-0.50.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ >=virtual/perl-Carp-1.260.0
+ >=virtual/perl-Scalar-List-Utils-1.290.0
+ >=virtual/perl-Test-Simple-0.980.0
+ )
+"
+src_test() {
+ perl_rm_files "t/02_pod.t" "t/03_pod_coverage.t" "t/release-pod-coverage.t" "t/release-pod-syntax.t"
+ perl-module_src_test
+}