summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/HTML-Mason
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/HTML-Mason')
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.540.0.ebuild61
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.560.0.ebuild66
-rw-r--r--dev-perl/HTML-Mason/Manifest2
-rw-r--r--dev-perl/HTML-Mason/metadata.xml49
4 files changed, 178 insertions, 0 deletions
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.540.0.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.540.0.ebuild
new file mode 100644
index 000000000000..f9ec1b99e80e
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.540.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=JSWARTZ
+MODULE_VERSION=1.54
+inherit depend.apache perl-module
+
+DESCRIPTION="A HTML development and delivery Perl Module"
+HOMEPAGE="http://www.masonhq.com/ ${HOMEPAGE}"
+
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="modperl test"
+
+RDEPEND="!modperl? ( dev-perl/CGI )
+ modperl? (
+ www-apache/libapreq2
+ >=www-apache/mod_perl-2
+ )
+ >=dev-perl/Params-Validate-0.7
+ >=dev-perl/Class-Container-0.08
+ >=dev-perl/Exception-Class-1.15
+ dev-perl/HTML-Parser
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-File-Spec
+ >=dev-perl/Cache-Cache-1.01
+ dev-perl/Log-Any"
+
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( dev-perl/Test-Deep )"
+
+want_apache2 modperl
+
+SRC_TEST="do"
+mydoc="CREDITS UPGRADE"
+myconf="--noprompts"
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ perl_set_version
+}
+
+src_prepare() {
+ # Note about new modperl use flag
+ if use !modperl ; then
+ ewarn "HTML-Mason will only install with modperl support"
+ ewarn "if the use flag modperl is enabled."
+ fi
+ # rendhalver - needed to set an env var for the build script so it finds our apache.
+ export APACHE="${APACHE_BIN}"
+ perl-module_src_prepare
+}
+
+src_install () {
+ perl-module_src_install
+ mv "${ED}"/usr/bin/convert* "${ED}"/usr/share/doc/${PF} || die
+}
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.560.0.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.560.0.ebuild
new file mode 100644
index 000000000000..c8ddb0ae0087
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.560.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=1.56
+inherit depend.apache perl-module
+
+DESCRIPTION="A HTML development and delivery Perl Module"
+HOMEPAGE="http://www.masonhq.com/ ${HOMEPAGE}"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="modperl test"
+
+RDEPEND="
+ !modperl? ( >=dev-perl/CGI-2.460.0 )
+ modperl? (
+ www-apache/libapreq2
+ >=www-apache/mod_perl-2
+ )
+ >=dev-perl/Cache-Cache-1
+ >=dev-perl/Class-Container-0.70.0
+ >=dev-perl/Exception-Class-1.150.0
+ virtual/perl-File-Spec
+ dev-perl/HTML-Parser
+ >=dev-perl/Log-Any-0.80.0
+ >=dev-perl/Params-Validate-0.70.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Deep
+ )
+"
+
+want_apache2 modperl
+
+SRC_TEST="do"
+mydoc="CREDITS UPGRADE"
+myconf="--noprompts"
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ perl_set_version
+}
+
+src_prepare() {
+ # Note about new modperl use flag
+ if use !modperl ; then
+ ewarn "HTML-Mason will only install with modperl support"
+ ewarn "if the use flag modperl is enabled."
+ fi
+ # rendhalver - needed to set an env var for the build script so it finds our apache.
+ export APACHE="${APACHE_BIN}"
+ perl-module_src_prepare
+}
+
+src_install () {
+ perl-module_src_install
+ mv "${ED}"/usr/bin/convert* "${ED}"/usr/share/doc/${PF} || die
+}
diff --git a/dev-perl/HTML-Mason/Manifest b/dev-perl/HTML-Mason/Manifest
new file mode 100644
index 000000000000..1dbb9faaaac4
--- /dev/null
+++ b/dev-perl/HTML-Mason/Manifest
@@ -0,0 +1,2 @@
+DIST HTML-Mason-1.54.tar.gz 302498 SHA256 a7657205a16e17049da9c9e0f8fac4a3c5fef23965e635372cbff6f2b8452219 SHA512 341548326391331b22d4adb60363b63149d13406bfe79683f5f69965811e9b6e43e36336b3503eca42792e70db589b264c093074635ea01860598cd90c6e1dc6 WHIRLPOOL c00d01bcbb48e55fd02b11235e6acba06389f5a11f5e6213b741c054e93663ff77dfa4a78481e7dce931ab41a5cb93323f8b4f2fcc8113813df81a2bc3a1648f
+DIST HTML-Mason-1.56.tar.gz 314167 SHA256 84ac24fb1d551f998145435265e5b6fd4a52ec61e4fadd3d7755eb648be2c4b2 SHA512 3492a37b8289209a2215b42be71db242ca150f4364d8422e46ca4762f2cdbddf96a56f44a3462d1f1eb23ef3bbe1cb36b8322106f4050404b988c6d90a05911c WHIRLPOOL bccf39f71a76fd54bf57a12f2da676611657fff7f28db73d5e7192f920ac5b3a124e0720ef094b697043e602ebf7320774cc0599944e2d00015a956e50b5f315
diff --git a/dev-perl/HTML-Mason/metadata.xml b/dev-perl/HTML-Mason/metadata.xml
new file mode 100644
index 000000000000..6f8534f86816
--- /dev/null
+++ b/dev-perl/HTML-Mason/metadata.xml
@@ -0,0 +1,49 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <use><flag name="modperl">Enable <pkg>www-apache/mod_perl</pkg>
+ support</flag>
+ </use>
+ <upstream>
+ <remote-id type="cpan">HTML-Mason</remote-id>
+ <remote-id type="cpan-module">HTML::Mason</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Apache::Request</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::ApacheHandler</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::CGIHandler</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Cache::BaseCache</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Compiler</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Compiler::ToObject</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Component</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Component::FileBased</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Component::Subcomponent</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::ComponentSource</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Escapes</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Exception</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Exception::Compilation</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Exception::Syntax</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Exceptions</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::FakeApache</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::FakeTable</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::FakeTableHash</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Handler</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Interp</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Lexer</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::MethodMaker</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Plugin</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Plugin::Context</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Plugin::Context::EndComponent</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Plugin::Context::EndRequest</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Plugin::Context::StartComponent</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Plugin::Context::StartRequest</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Request</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Request::ApacheHandler</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Request::CGI</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Resolver</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Resolver::File</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Resolver::Null</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Tools</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Utils</remote-id>
+ <remote-id type="cpan-module">Tie::Handle::Mason</remote-id>
+ </upstream>
+</pkgmetadata>