summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-01 09:17:59 +0100
committerSam James <sam@gentoo.org>2024-05-01 09:23:15 +0100
commit93926004758ba41a82f8c587b9cd7ae4cc1fe62e (patch)
tree9b7bd17074749220701c160b7a17318dacc3614e /dev-perl/Exception-Base
parentmedia-sound/schismtracker: dropped obsolete 20240308 (diff)
downloadgentoo-93926004758ba41a82f8c587b9cd7ae4cc1fe62e.tar.gz
gentoo-93926004758ba41a82f8c587b9cd7ae4cc1fe62e.tar.bz2
gentoo-93926004758ba41a82f8c587b9cd7ae4cc1fe62e.zip
dev-perl/Exception-Base: fix tests w/ perl-5.38
Closes: https://bugs.gentoo.org/928246 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Exception-Base')
-rw-r--r--dev-perl/Exception-Base/Exception-Base-0.250.100-r2.ebuild26
-rw-r--r--dev-perl/Exception-Base/files/Exception-Base-0.2501-perl-5.38.patch15
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Exception-Base/Exception-Base-0.250.100-r2.ebuild b/dev-perl/Exception-Base/Exception-Base-0.250.100-r2.ebuild
new file mode 100644
index 000000000000..48e9926b2c4c
--- /dev/null
+++ b/dev-perl/Exception-Base/Exception-Base-0.250.100-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=DEXTER
+DIST_VERSION=0.2501
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Error handling with exception class"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-perl/Module-Build"
+BDEPEND="
+ dev-perl/Module-Build
+ test? (
+ >=dev-perl/Test-Unit-Lite-0.120.0
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/Exception-Base-0.2501-perl-5.38.patch
+)
diff --git a/dev-perl/Exception-Base/files/Exception-Base-0.2501-perl-5.38.patch b/dev-perl/Exception-Base/files/Exception-Base-0.2501-perl-5.38.patch
new file mode 100644
index 000000000000..64168cfa39a8
--- /dev/null
+++ b/dev-perl/Exception-Base/files/Exception-Base-0.2501-perl-5.38.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/928246
+https://github.com/dex4er/perl-Exception-Base/issues/5
+
+--- a/t/tlib/Exception/BaseTest.pm
++++ b/t/tlib/Exception/BaseTest.pm
+@@ -569,7 +569,8 @@
+ $self->assert_matches(qr/String at /, $obj);
+
+ # smart matching for Perl 5.10
+- if ($] >= 5.010) {
++ # Deprecation warning added in 5.37.10
++ if ($] >= 5.010 && $] < 5.037010) {
+ no if $] >= 5.018, warnings => 'experimental::smartmatch';
+ eval q{
+ $self->assert_num_equals(1, 'String' ~~ $obj);