summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-04 22:17:20 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-04 22:17:39 +1200
commit6f374d55a29bc4a0bd83f84fdf4c16a8c680b95d (patch)
tree59aa4b122236b30dbd423aff6cb59e0ff286de45 /dev-perl/Dist-Zilla-Plugin-ReadmeAnyFromPod/Dist-Zilla-Plugin-ReadmeAnyFromPod-0.163.250-r1.ebuild
parentprofiles: cleanup (diff)
downloadgentoo-6f374d55a29bc4a0bd83f84fdf4c16a8c680b95d.tar.gz
gentoo-6f374d55a29bc4a0bd83f84fdf4c16a8c680b95d.tar.bz2
gentoo-6f374d55a29bc4a0bd83f84fdf4c16a8c680b95d.zip
dev-perl/Dist-Zilla-Plugin-ReadmeAnyFromPod: -r bump for overlay compat
- bumping to -r1 to ensure this one takes precedence over the version presently still available in ::perl-experimental, which has somewhat different behaviour and is outdated. Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Dist-Zilla-Plugin-ReadmeAnyFromPod/Dist-Zilla-Plugin-ReadmeAnyFromPod-0.163.250-r1.ebuild')
-rw-r--r--dev-perl/Dist-Zilla-Plugin-ReadmeAnyFromPod/Dist-Zilla-Plugin-ReadmeAnyFromPod-0.163.250-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/Dist-Zilla-Plugin-ReadmeAnyFromPod/Dist-Zilla-Plugin-ReadmeAnyFromPod-0.163.250-r1.ebuild b/dev-perl/Dist-Zilla-Plugin-ReadmeAnyFromPod/Dist-Zilla-Plugin-ReadmeAnyFromPod-0.163.250-r1.ebuild
new file mode 100644
index 000000000000..ecf3f2ef35ee
--- /dev/null
+++ b/dev-perl/Dist-Zilla-Plugin-ReadmeAnyFromPod/Dist-Zilla-Plugin-ReadmeAnyFromPod-0.163.250-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=RTHOMPSON
+DIST_VERSION=0.163250
+inherit perl-module
+
+DESCRIPTION="Automatically convert POD to a README in any format for Dist::Zilla"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Dist-Zilla
+ dev-perl/Dist-Zilla-Role-FileWatcher
+ virtual/perl-Encode
+ dev-perl/Moose
+ dev-perl/MooseX-Has-Sugar
+ dev-perl/PPI
+ >=dev-perl/Path-Tiny-0.4.0
+ >=dev-perl/Pod-Markdown-2.0.0
+ dev-perl/Pod-Markdown-Github
+ >=virtual/perl-Pod-Simple-3.230.0
+ >=virtual/perl-Scalar-List-Utils-1.330.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Carp
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ dev-perl/Test-Deep
+ dev-perl/Test-Fatal
+ dev-perl/Test-Most
+ dev-perl/Test-Requires
+ >=virtual/perl-Test-Simple-0.940.0
+ virtual/perl-autodie
+ )
+"
+PERL_RM_FILES=(
+ "t/author-critic.t"
+ "t/author-pod-coverage.t"
+ "t/author-pod-syntax.t"
+ "t/release-has-version.t"
+ "t/release-kwalitee.t"
+ "t/release-portability.t"
+ "t/release-unused-vars.t"
+)