summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-01 23:08:11 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-01 23:10:06 +1200
commit543233cebfdc398fb4c88f9005026bc3bf20b037 (patch)
treef8aa9538e28ea1011668316fbbf9be5591de5a0b /dev-perl/Crypt-IDEA
parentx11-wm/dwm: Old (diff)
downloadgentoo-543233cebfdc398fb4c88f9005026bc3bf20b037.tar.gz
gentoo-543233cebfdc398fb4c88f9005026bc3bf20b037.tar.bz2
gentoo-543233cebfdc398fb4c88f9005026bc3bf20b037.zip
dev-perl/Crypt-IDEA: -r bump for CFLAGS love
- Ensure CFLAGS are handed through make to cc Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-IDEA')
-rw-r--r--dev-perl/Crypt-IDEA/Crypt-IDEA-1.100.0-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Crypt-IDEA/Crypt-IDEA-1.100.0-r2.ebuild b/dev-perl/Crypt-IDEA/Crypt-IDEA-1.100.0-r2.ebuild
new file mode 100644
index 000000000000..b093191e6191
--- /dev/null
+++ b/dev-perl/Crypt-IDEA/Crypt-IDEA-1.100.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DPARIS
+DIST_VERSION=1.10
+inherit perl-module
+
+DESCRIPTION="An implementation of the IDEA symmetric-key block cipher"
+
+LICENSE="Crypt-IDEA"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=""
+BDEPEND="virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}