summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Cairo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Cairo')
-rw-r--r--dev-perl/Cairo/Cairo-1.103.0.ebuild34
-rw-r--r--dev-perl/Cairo/Cairo-1.105.0.ebuild35
-rw-r--r--dev-perl/Cairo/Manifest2
-rw-r--r--dev-perl/Cairo/metadata.xml9
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-perl/Cairo/Cairo-1.103.0.ebuild b/dev-perl/Cairo/Cairo-1.103.0.ebuild
new file mode 100644
index 000000000000..b3ee47643fc5
--- /dev/null
+++ b/dev-perl/Cairo/Cairo-1.103.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=XAOC
+MODULE_VERSION=1.103
+inherit perl-module
+
+DESCRIPTION="Perl interface to the cairo library"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=x11-libs/cairo-1.0.0
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/ExtUtils-Depends-0.205.0
+ >=dev-perl/extutils-pkgconfig-1.70.0
+ test? (
+ dev-perl/Test-Number-Delta
+ )
+"
+
+SRC_TEST="do"
+
+src_prepare() {
+ perl-module_src_prepare
+ sed -i -e 's,exit 0,exit 1,' "${S}"/Makefile.PL || die
+}
diff --git a/dev-perl/Cairo/Cairo-1.105.0.ebuild b/dev-perl/Cairo/Cairo-1.105.0.ebuild
new file mode 100644
index 000000000000..3000242b6570
--- /dev/null
+++ b/dev-perl/Cairo/Cairo-1.105.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=XAOC
+MODULE_VERSION=1.105
+inherit perl-module
+
+DESCRIPTION="Perl interface to the cairo library"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=x11-libs/cairo-1.0.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/ExtUtils-Depends-0.200.0
+ >=dev-perl/extutils-pkgconfig-1.0.0
+ test? (
+ dev-perl/Test-Number-Delta
+ )
+"
+
+SRC_TEST="do"
+
+src_prepare() {
+ perl-module_src_prepare
+ sed -i -e 's,exit 0,exit 1,' "${S}"/Makefile.PL || die
+}
diff --git a/dev-perl/Cairo/Manifest b/dev-perl/Cairo/Manifest
new file mode 100644
index 000000000000..8d0d18d370e4
--- /dev/null
+++ b/dev-perl/Cairo/Manifest
@@ -0,0 +1,2 @@
+DIST Cairo-1.103.tar.gz 108254 SHA256 eaebd9c3b9d66b4c41533ec7c736a2a4b73e0bf6ad207132a970d83a85827872 SHA512 d7e7488af7e52834762f0baef48687989fc64c44518c1b5c4312299bba4a3a0f69e5af05fac02440ae70fb1dd474fae9974f8913809c1b17fcabf7527bc68b46 WHIRLPOOL 79ff6d205be88167adac29303aac6c2219d9637671f4d4d707841bdac09803891861f37a46451eeef96746ffe1f22791af60146711a1eee8b5690faa66e5774f
+DIST Cairo-1.105.tar.gz 108695 SHA256 98201dea8f31a369bbf9b276065425dd58b710a8d14478d6e1868ce07911a046 SHA512 45e2712aca89eedc68b205f6aa6baa7b4c44c8f09da91aef02b08f1b148594c4332a6f81976c53f561ba94b8d63de6ce227dadb25e11e0796ac77bf1a310fbbf WHIRLPOOL 65807dbb4e015ecff4600f8593b01cc20ba2cc120f1e99bb669ba7303a47a3e0b62cca1bbd6f1338f8631589c7656d5ce20715648382742682c9b6b167496528
diff --git a/dev-perl/Cairo/metadata.xml b/dev-perl/Cairo/metadata.xml
new file mode 100644
index 000000000000..e1a11e9e2fa5
--- /dev/null
+++ b/dev-perl/Cairo/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Cairo</remote-id>
+ <remote-id type="cpan-module">Cairo</remote-id>
+ </upstream>
+</pkgmetadata>