summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-06 06:27:47 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-06 06:27:47 +1200
commit900cc3ec5673c51d45e7c06a382402c323e34781 (patch)
tree74c7895715f96b466694381955f7b36e80058cb9 /dev-perl/CDB_File/CDB_File-1.20.0-r1.ebuild
parentdev-perl/CBOR-XS: -r bump for CFLAGS love (diff)
downloadgentoo-900cc3ec5673c51d45e7c06a382402c323e34781.tar.gz
gentoo-900cc3ec5673c51d45e7c06a382402c323e34781.tar.bz2
gentoo-900cc3ec5673c51d45e7c06a382402c323e34781.zip
dev-perl/CDB_File: -r bump for CFLAGS love
- Ensure CFLAGS passed to make/compile Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/CDB_File/CDB_File-1.20.0-r1.ebuild')
-rw-r--r--dev-perl/CDB_File/CDB_File-1.20.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/CDB_File/CDB_File-1.20.0-r1.ebuild b/dev-perl/CDB_File/CDB_File-1.20.0-r1.ebuild
new file mode 100644
index 000000000000..a753c1041d5f
--- /dev/null
+++ b/dev-perl/CDB_File/CDB_File-1.20.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TODDR
+DIST_VERSION=1.02
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Tie to CDB (Bernstein's constant DB) files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/B-COW
+ virtual/perl-File-Temp
+ virtual/perl-Test-Simple
+ )
+"
+# Parallel breaks
+DIST_TEST="do"
+
+src_prepare() {
+ mkdir "${S}/examples" || die "Can't make examples dir"
+ einfo "Moving bun-x.pl to examples/"
+ cp "${S}/bun-x.pl" "${S}/examples/" || die "Can't copy example to examples/"
+ perl_rm_files bun-x.pl
+ perl-module_src_prepare
+}
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}