summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-04 00:52:54 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-04 02:59:32 +1200
commit774c4695cd035ddd7289de4b0d13795311957989 (patch)
tree5ac1e4de40956aeb1df8d024bd3216306f07051c /dev-perl/B-COW
parentdev-erlang/xmpp: Version bump (diff)
downloadgentoo-774c4695cd035ddd7289de4b0d13795311957989.tar.gz
gentoo-774c4695cd035ddd7289de4b0d13795311957989.tar.bz2
gentoo-774c4695cd035ddd7289de4b0d13795311957989.zip
dev-perl/B-COW: -r Bump for CFLAGS love
- Ensure CFLAGS passed to make/compiler Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/B-COW')
-rw-r--r--dev-perl/B-COW/B-COW-0.4.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/B-COW/B-COW-0.4.0-r1.ebuild b/dev-perl/B-COW/B-COW-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..c72eff3865ee
--- /dev/null
+++ b/dev-perl/B-COW/B-COW-0.4.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ATOOMIC
+DIST_VERSION=0.004
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="additional B helpers to check COW status"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Test-Simple
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}