summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 17:58:46 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commit92cc1f5b43e47ad21c53841fd8d52beec7e36c5b (patch)
tree7960e3083472635553b05d4e4434bae2115f9935 /dev-ml
parentdev-ml/ppx_bin_prot: Use proper install method (diff)
downloadgentoo-92cc1f5b43e47ad21c53841fd8d52beec7e36c5b.tar.gz
gentoo-92cc1f5b43e47ad21c53841fd8d52beec7e36c5b.tar.bz2
gentoo-92cc1f5b43e47ad21c53841fd8d52beec7e36c5b.zip
dev-ml/ppx_inline_test: Use proper install method.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ppx_inline_test/ppx_inline_test-113.24.00.ebuild21
1 files changed, 16 insertions, 5 deletions
diff --git a/dev-ml/ppx_inline_test/ppx_inline_test-113.24.00.ebuild b/dev-ml/ppx_inline_test/ppx_inline_test-113.24.00.ebuild
index 7800841951f4..65a421984f33 100644
--- a/dev-ml/ppx_inline_test/ppx_inline_test-113.24.00.ebuild
+++ b/dev-ml/ppx_inline_test/ppx_inline_test-113.24.00.ebuild
@@ -21,13 +21,24 @@ DEPEND="dev-ml/ppx_tools:=
dev-ml/ppx_core:="
RDEPEND="${DEPEND}"
-DEPEND="${DEPEND} dev-ml/oasis"
+DEPEND="${DEPEND} dev-ml/opam"
S="${WORKDIR}/${MY_P}"
-DOCS=( CHANGES.md )
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
-src_prepare() {
- sed -i -e "s/Executable ppx/Executable ${PN}/" _oasis || die
- oasis setup || die
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
}