summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-11-22 08:39:42 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-11-22 08:40:16 +0100
commit639aec68634d312b1eecedc31a8f8d3f242ffa4f (patch)
treecfcf1d8706953f8e4825399c80822bf4067a8c40 /dev-ml
parentapp-arch/dpkg: add 1.21.9, unkeyworded. (diff)
downloadgentoo-639aec68634d312b1eecedc31a8f8d3f242ffa4f.tar.gz
gentoo-639aec68634d312b1eecedc31a8f8d3f242ffa4f.tar.bz2
gentoo-639aec68634d312b1eecedc31a8f8d3f242ffa4f.zip
dev-ml/dune: add 3.2.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/dune/Manifest1
-rw-r--r--dev-ml/dune/dune-3.2.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-ml/dune/Manifest b/dev-ml/dune/Manifest
index 6092ecc9038b..c8df7791ba79 100644
--- a/dev-ml/dune/Manifest
+++ b/dev-ml/dune/Manifest
@@ -3,3 +3,4 @@ DIST dune-2.9.1.tar.gz 1385381 BLAKE2B 27224f803547d02f7110dcfc486ef41f9a4586f6f
DIST dune-2.9.3.tar.gz 1387667 BLAKE2B 3db54c780b9d13f40c774f53c3fe471dba4a640e7cb5aa5d70ef1dc20a217b95a66149ca5f99f07f3a20450577d622e0cda149f656f06f5a42231b89667c1152 SHA512 df6e06a9beebf41f3ed375384be781b5c87c7949048995cc0bbad13dd65c96bd8b27415cd41e43b1112bd86524a59a7dd418e14b5c72b4f1f8fd4ac5ca2d1494
DIST dune-3.0.3.tar.gz 1725788 BLAKE2B 2de93c085f642c8381642a08b18bc21ad48097f32397b3eddab9725deb267b089849b649705e1b72bb1b5b37f7531fd9e0cfb134174f0cb3a8ee2595c7dcf8ce SHA512 839e942bcf8189763d0d9b01614333bb2f036bce68c82959e51d2e9145b57067cb862b66781912391c1a0f531b8dddf2ffeafcee71c626169a437fe40feba155
DIST dune-3.1.1.tar.gz 1738713 BLAKE2B 29e2034a551f9fbc57aeb1056f934ee5b69d38743178743f9b4f9cfa9e43a805ef7eb904a25f5ff6b4944d47032ccb1c8fb420b48f85dd14bdd14350cc53f77c SHA512 3a99a66c449f9e6bf12bb21d2d6871f4d34677a8c0c63e47b3687e2af3d8c62ab4ab62809c5885f2d61a1ed93a88f90cadc0f8db0c95442410c0a964892bd3b8
+DIST dune-3.2.0.tar.gz 1754664 BLAKE2B 97ba420a5bf9dd8e14ba74c0e91b6679924fd9ee7b8d9a9a2d4b282166d9172582a37adf408fd037972dab7525cd240c24729b6692f403c32029b2994044bd40 SHA512 a90ac689d97acab956fd96f16f7c6cfdc95d01785fc14f0d3c8ab39231ff78e8941d2db2fa8cbfaa39bbed8f865e11b628aacae1b22df49512a57d0263c0dca4
diff --git a/dev-ml/dune/dune-3.2.0.ebuild b/dev-ml/dune/dune-3.2.0.ebuild
new file mode 100644
index 000000000000..b406b7f73f41
--- /dev/null
+++ b/dev-ml/dune/dune-3.2.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing elisp-common
+
+DESCRIPTION="A composable build system for OCaml"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="emacs"
+RESTRICT="strip test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08:=
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+DEPEND="${RDEPEND}"
+
+QA_FLAGS_IGNORED="usr/bin/dune"
+
+BYTECOMPFLAGS="-L ${S}/editor-integration/emacs"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+
+ # This allows `dune --version` to output the correct version
+ # instead of "n/a"
+ sed -i "/^(name dune)/a (version ${PV})" dune-project || die
+}
+
+src_configure() {
+ ./configure \
+ --libdir="$(ocamlc -where)" \
+ --mandir=/usr/share/man \
+ --docdir=/usr/doc \
+ --etcdir=/etc \
+ --datadir=/usr/share \
+ --sbindir=/usr/sbin \
+ --bindir=/usr/bin \
+ || die
+}
+
+src_compile() {
+ ocaml bootstrap.ml -j $(makeopts_jobs) || die
+ ./dune.exe build -p "${PN}" --profile dune-bootstrap -j $(makeopts_jobs) \
+ --display short || die
+
+ use emacs && elisp-compile editor-integration/emacs/*.el
+}
+
+src_install() {
+ default
+
+ dodir /usr/share/doc
+ mv "${ED}"/usr/doc/dune "${ED}"/usr/share/doc/${PF} || die
+ rmdir "${ED}"/usr/doc || die
+
+ if use emacs ; then
+ elisp-install ${PN} editor-integration/emacs/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}