summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-06 03:35:43 +0000
committerSam James <sam@gentoo.org>2021-11-06 03:35:43 +0000
commit5c12941dc7a47c6497869981ba769f3c9f8b4ffb (patch)
tree40a09b3d18944247eb769745237cfd800ab193fa /dev-ml
parentdev-ml/opam-solver: add 2.1.1 (diff)
downloadgentoo-5c12941dc7a47c6497869981ba769f3c9f8b4ffb.tar.gz
gentoo-5c12941dc7a47c6497869981ba769f3c9f8b4ffb.tar.bz2
gentoo-5c12941dc7a47c6497869981ba769f3c9f8b4ffb.zip
dev-ml/opam-installer: add 2.1.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/opam-installer/Manifest1
-rw-r--r--dev-ml/opam-installer/opam-installer-2.1.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/opam-installer/Manifest b/dev-ml/opam-installer/Manifest
index 97c8e1c8c006..8f2c10b6c1c6 100644
--- a/dev-ml/opam-installer/Manifest
+++ b/dev-ml/opam-installer/Manifest
@@ -3,3 +3,4 @@ DIST opam-full-2.0.10.tar.gz 8173617 BLAKE2B 6bf7a52835512b3de5bcf0de24f5ba3a322
DIST opam-full-2.0.8.tar.gz 8006252 BLAKE2B 26348bdbb8bdc2fbf9d736286c1f4134ce065e8c15e34d51c8d2c6e5338fd6db089df38a19b07cde70770724fc4cc3dbd9e7d75628e5435ca8a2f8c0d4d3f2f0 SHA512 f08893ad0c1e124368168f28dcb5c3293e443da712d7b12db432c21ff72f7e1440bcc7156f49661d286360a16dcd166d3d02ecdebf8b1cda7c7df2b22e48f80f
DIST opam-full-2.0.9.tar.gz 8029605 BLAKE2B c2ae06bdbbdbe9db270ec0027ec8d13a228f0af2ae5089476fa3a698d27e1f47abf2e3a15ecc9ca610717ba6b979b4ca76cce56c52f6592ae789b88fb5e5b68d SHA512 9f44d878a2599a876f5e5b9b7457b6f446a5e59156ed3d449dcc29e40c44df8b69da619eabdf030e45526fba4bd9a00c65dec2c36552d2e03788596b0aceee85
DIST opam-full-2.1.0.tar.gz 9136886 BLAKE2B 3d51159568b6e85834f70a3545fe37d82470d4253bf9db6fef32b4314fd0a82182737bba6be62a9dd04b6d8fb8d7468b2e23ac39fa475f467adfdb0ec8d52181 SHA512 2c4955e450cde7211dbab507cbdc5d6e67805353e384df525d77ebf5561d6a4de91f7e5691567b2dc61146fc29df6fa5dc8aa8562330a4746db3a52b7487811a
+DIST opam-full-2.1.1.tar.gz 9275192 BLAKE2B b5729bc938633073efdf979f8e160c42aee682fe311b613d4d82be7add64b42506d1b6c107f3770fd8de4dc9eed7076f7774a34482d1956b8bd6315f551aea6d SHA512 7876a015fc2a421f70f9e8fa35c7ce56397dde7b679f3aba73c2a38f4967afc410c707a00f0a107baf353efe8bb6d4eee0601a5e205dc05a0f9c3d2a0c4d44d8
diff --git a/dev-ml/opam-installer/opam-installer-2.1.1.ebuild b/dev-ml/opam-installer/opam-installer-2.1.1.ebuild
new file mode 100644
index 000000000000..1ea426a6380d
--- /dev/null
+++ b/dev-ml/opam-installer/opam-installer-2.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+OPAM_SKIP_VALIDATION=yes
+inherit dune
+
+DESCRIPTION="Core installer for opam packages"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-full-${PV}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/dev-ml/opam/opam-2.1.0-dose3-6.patch.xz"
+S="${WORKDIR}/opam-full-${PV/_/-}"
+OPAM_INSTALLER="${S}/_build/install/default/bin/opam-installer"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+PATCHES=( "${WORKDIR}"/opam-2.1.0-dose3-6.patch )
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02.3
+ dev-ml/cmdliner:=
+ ~dev-ml/opam-format-${PV}
+ >=dev-ml/dose3-6
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib"
+
+src_configure() {
+ econf \
+ --prefix="${EPREFIX}/usr" \
+ --with-mccs \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --mandir="${EPREFIX}/usr/share/man"
+}