summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-03-09 00:35:22 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-03-09 02:36:44 +0100
commit40789a898b65633bafac77d0e2350acef3c3821b (patch)
tree9448bd2d8f5a6ef70c2bb663ff5230d2f15d3ef0 /dev-ml
parentRevert "dev-cpp/pangomm: drop 2.42.2-r1" (diff)
downloadgentoo-40789a898b65633bafac77d0e2350acef3c3821b.tar.gz
gentoo-40789a898b65633bafac77d0e2350acef3c3821b.tar.bz2
gentoo-40789a898b65633bafac77d0e2350acef3c3821b.zip
dev-ml/reason: bump to 3.8.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/reason/Manifest1
-rw-r--r--dev-ml/reason/reason-3.8.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/reason/Manifest b/dev-ml/reason/Manifest
index 85e869fa7c98..23c04f1b3366 100644
--- a/dev-ml/reason/Manifest
+++ b/dev-ml/reason/Manifest
@@ -1,2 +1,3 @@
DIST reason-3.7.0.tgz 1188558 BLAKE2B e5d9cebf98f95824b78d440fa9f91460eae1a1ed44a38e74be4f9404a0bdec046578d25febdf55c266466bffc16b4449e982f157b6d5aabfa1d507fdc3eb5aaf SHA512 263059970c88e105f09e8e47b3967add11fda31a79942f573c90a0ccb04149a5baaf3c3bbd1dd5a085ccdd3e63505f84855dd0fb888d34a9e9eda3248f300e24
DIST reason-3.7.0_p20211014.tar.gz 1182345 BLAKE2B 2bd69011b80ef6e86dc4838e3612d2992e5aef865686362339b8e536c339ceeac852b948f1e495b9dcb5210302804d886c19e663d2333b477903915630c4a5f5 SHA512 a3923c5da1c4baa8e7292bbc066330cbebc2e090c301cbffb09b9753dbd241b502a8a9b0d92257d4f5e202e0b8cce6a579e934b4e877f987ec326fdd75d39620
+DIST reason-3.8.0.tar.gz 1216708 BLAKE2B 99e214a5ff24d0745c35c2522e9b9182fb3db624beb4d843a8e2e27a1e0b93c19e23d1bf44828b216bc58a6f6d447412ead76ffa351e4b3a63607202efd46d31 SHA512 54da28cbdbfb82d76a49f155c929a059e32b4d9e0bc63629b2f7a1206ae56482148519136c24a7bbfcb0a8ba5185070e89ffa187964feeec5e73328edeb754e4
diff --git a/dev-ml/reason/reason-3.8.0.ebuild b/dev-ml/reason/reason-3.8.0.ebuild
new file mode 100644
index 000000000000..29a823b9621d
--- /dev/null
+++ b/dev-ml/reason/reason-3.8.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Simple, fast & type safe language that leverages JavaScript and OCaml"
+HOMEPAGE="https://reasonml.github.io"
+SRC_URI="https://github.com/reasonml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/fix:=
+ dev-ml/menhir:=
+ dev-ml/merlin-extend:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/result:=
+ dev-ml/utop:=
+"
+DEPEND="${RDEPEND}"
+
+DOCS=(
+ CODE_OF_CONDUCT.md HISTORY.md ORIGINS.md PLAN README.md
+ docs/GETTING_STARTED_CONTRIBUTING.md
+ docs/TYPE_PARAMETERS_PARSING.md
+ docs/USING_PARSER_PROGRAMMATICALLY.md
+)
+
+src_install() {
+ dune-install reason rtop
+ einstalldocs
+}