summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-17 09:53:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-17 09:53:20 +0200
commit1be071429ba0a79475a87592e192c445cd60f2b3 (patch)
tree1d80be52afeab6d0a329b2d4dfe76452392b349e /dev-ml
parentdev-ml/ocaml-cairo: Add missing svg usedep on cairo, bug #618672 (diff)
downloadgentoo-1be071429ba0a79475a87592e192c445cd60f2b3.tar.gz
gentoo-1be071429ba0a79475a87592e192c445cd60f2b3.tar.bz2
gentoo-1be071429ba0a79475a87592e192c445cd60f2b3.zip
dev-ml/atd: Bump to 1.2.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/atd/Manifest1
-rw-r--r--dev-ml/atd/atd-1.2.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/atd/Manifest b/dev-ml/atd/Manifest
index ff0f798a76d5..e529ea6d8148 100644
--- a/dev-ml/atd/Manifest
+++ b/dev-ml/atd/Manifest
@@ -1 +1,2 @@
DIST atd-1.2.0.tar.gz 41300 SHA256 488e06e406824efab12f53845b648c1a592c2c8349d4ac1e12b94ce61e7453e9 SHA512 a52824c9784ac0f4d6f314972fa1d92be14730de3c6bde04032004579ac27408385bd4fa7d926f9d564657eb62050fd732a032f364bada62a1dc7a8acfacb727 WHIRLPOOL b0fe31df2282e5533c6c5bc769a9dfedfc60b5457ccf5e0b7fed82d1da287b72cee3bf1133891e2abe674afb70df781a94200e17bdb0011a45af3f492ae38b1e
+DIST atd-1.2.1.tar.gz 39018 SHA256 515663f1c48c3592e360079f92eea6db82d3d989f1df19b45e8179aec0d48e34 SHA512 5dde8dd1e6ca53ae2ff7efc873211079678a824ae7a9d4182d58e3e10ce50a9dcd705de7168a8cfb12ea3d030a0d01b2485d436e77bfa48c14df7628b47161dc WHIRLPOOL 666cb45158769c98f1bd6b30e045447441cea0cfd54d803b88a3e1ae3b2fd355e351f5cfa5e86c8f96e9dbf44d56920748b639f31f7b4787f0d5f634ef7c2c57
diff --git a/dev-ml/atd/atd-1.2.1.ebuild b/dev-ml/atd/atd-1.2.1.ebuild
new file mode 100644
index 000000000000..d57bf461c6d4
--- /dev/null
+++ b/dev-ml/atd/atd-1.2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="Syntax for cross-language type definitions"
+HOMEPAGE="https://github.com/mjambon/atd"
+SRC_URI="https://github.com/mjambon/atd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/easy-format:=[ocamlopt?]
+ dev-ml/menhir:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}