summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-02 12:07:57 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-02 13:22:38 +0200
commit0ebbfe9b207f6f8d0eff982a0f7c8df1a3187349 (patch)
tree18ef40a8928d35bd0b9f53f393bafa1f1f608cc2 /dev-ml/zed
parentopam.eclass: Initial import. (diff)
downloadgentoo-0ebbfe9b207f6f8d0eff982a0f7c8df1a3187349.tar.gz
gentoo-0ebbfe9b207f6f8d0eff982a0f7c8df1a3187349.tar.bz2
gentoo-0ebbfe9b207f6f8d0eff982a0f7c8df1a3187349.zip
dev-ml/zed: convert to opam.eclass
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ml/zed')
-rw-r--r--dev-ml/zed/zed-1.5.ebuild12
1 files changed, 2 insertions, 10 deletions
diff --git a/dev-ml/zed/zed-1.5.ebuild b/dev-ml/zed/zed-1.5.ebuild
index 844d092dc96d..c8a407083927 100644
--- a/dev-ml/zed/zed-1.5.ebuild
+++ b/dev-ml/zed/zed-1.5.ebuild
@@ -3,6 +3,8 @@
EAPI=5
+inherit opam
+
DESCRIPTION="Zed is an abstract engine for text edition"
HOMEPAGE="https://github.com/diml/zed"
SRC_URI="https://github.com/diml/zed/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -18,18 +20,8 @@ DEPEND="
dev-ml/react:="
RDEPEND="${DEPEND}"
DEPEND="${DEPEND}
- dev-ml/opam
dev-ml/jbuilder"
src_compile() {
jbuilder build --only-packages zed @install || die
}
-
-src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
- dodoc CHANGES.md README.md
-}