summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-04-26 08:29:36 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-04-26 08:30:02 +0200
commit7dd8303fb5101c7e3558c806dd35b6cc2f284e0e (patch)
treec3408807472bcb257a36ac2d47c61d1fcd575396 /dev-ml/ppx_js_style
parentpackage.mask: add ppx_js_style to janestreet mask (diff)
downloadgentoo-7dd8303fb5101c7e3558c806dd35b6cc2f284e0e.tar.gz
gentoo-7dd8303fb5101c7e3558c806dd35b6cc2f284e0e.tar.bz2
gentoo-7dd8303fb5101c7e3558c806dd35b6cc2f284e0e.zip
dev-ml/ppx_js_style: 0.15.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_js_style')
-rw-r--r--dev-ml/ppx_js_style/Manifest1
-rw-r--r--dev-ml/ppx_js_style/ppx_js_style-0.15.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/ppx_js_style/Manifest b/dev-ml/ppx_js_style/Manifest
index 4ca1d811d6ed..833d13258669 100644
--- a/dev-ml/ppx_js_style/Manifest
+++ b/dev-ml/ppx_js_style/Manifest
@@ -1,2 +1,3 @@
DIST ppx_js_style-0.14.0.tar.gz 10587 BLAKE2B 8219a69526be53b9fce488f725c79ff30c451c556853aa54d8dbbd7040a76df37ac8942ae05cdcbbe6d839a64d5b471f53a2fce276e547a17e68490c1ec1ab19 SHA512 3561b7668bafc421fa82c3c80e019185924bfc8cafab6ef81299395061db78261005bdd34be5bed8a80bec84306b9294e6398a3a1ee0a269f7b8f3942953a6a4
DIST ppx_js_style-0.14.1.tar.gz 10587 BLAKE2B a77868e692180a386622fc19f696a24a9cd33863289a673d142c63003e5345a9cbe8921a7c1cf163db97f21da45c4940978f4e5d6960abc1fbc44b4283f09b42 SHA512 7c96d0e21c68956f3c94d6b6f02d70451d7e041104975171c8fb1c0f5dbcdf5b2111c5d05b247a47523abc7cf30b9d20cac267e542db459154edfe77516d2c46
+DIST ppx_js_style-0.15.0.tar.gz 10647 BLAKE2B d7cf2efa261383084a8f4bfc2508d8c345415b50e6ea83128bd40cffbcbe7eabc8fbb3037176ba73c303de199ca3cc96925e077c123a7f3a68e0a5c7470d56eb SHA512 10e4e9d737551538cdd89466acf76df04e87669f00236bc89fcad318b862efcee94f59a687d07fe5a559c00a59954b07185dd39e034d4a15869c281eea2bec4e
diff --git a/dev-ml/ppx_js_style/ppx_js_style-0.15.0.ebuild b/dev-ml/ppx_js_style/ppx_js_style-0.15.0.ebuild
new file mode 100644
index 000000000000..a35563b5c809
--- /dev/null
+++ b/dev-ml/ppx_js_style/ppx_js_style-0.15.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Code style checker for Jane Street Packages"
+HOMEPAGE="https://github.com/janestreet/ppx_js_style"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/base:${SLOT}
+ dev-ml/findlib:=
+ dev-ml/octavius:=
+ >=dev-ml/ppxlib-0.23.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+"
+RDEPEND="${DEPEND}"