summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-09 01:38:34 +0000
committerSam James <sam@gentoo.org>2022-01-09 01:38:34 +0000
commit254233865f3f9acfc8fc180ddcba9cebde02ade8 (patch)
treec899d4a4e602caaf4d5e09103a7ad69877425ef5 /dev-ml/ocurl
parentsys-apps/haveged: add 1.9.17 (diff)
downloadgentoo-254233865f3f9acfc8fc180ddcba9cebde02ade8.tar.gz
gentoo-254233865f3f9acfc8fc180ddcba9cebde02ade8.tar.bz2
gentoo-254233865f3f9acfc8fc180ddcba9cebde02ade8.zip
dev-ml/ocurl: add 0.9.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/ocurl')
-rw-r--r--dev-ml/ocurl/Manifest1
-rw-r--r--dev-ml/ocurl/ocurl-0.9.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/ocurl/Manifest b/dev-ml/ocurl/Manifest
index 6c6fc0aaa928..4bc3d1319a6a 100644
--- a/dev-ml/ocurl/Manifest
+++ b/dev-ml/ocurl/Manifest
@@ -1 +1,2 @@
DIST ocurl-0.9.1.tar.gz 111393 BLAKE2B 83ec8f5e2e83b5cc519683556ca97818a092a80f41305394cc04088371c1179f256dee3d8a8e80597837fb156299698450c70ca00f1ec336ace46b02b84bb51e SHA512 f4acb596f213ce57e749c9805225330b532e17718f3b228745b438cd1fe6d89b37e56d401a11c329107729dd0e6bdd4a425d547f9a83dabe32edbf18aca585b5
+DIST ocurl-0.9.2.tar.gz 116659 BLAKE2B 3947cd82343cc9246c930f8fc89f7899f41a06f41358b5a014fbd05f5c85e70eb3df8c10690e62bd76d345c5738fdab63a936deed53fde0c8a3b040c5890129f SHA512 de9b06a2a4cbf804b6c947ef1011a75f45e3effbc29db054a9b72453920a0f554baa06d06b2a36eeee33090df7f9eb35280404237e2e3be219fb2dc98fe2bc82
diff --git a/dev-ml/ocurl/ocurl-0.9.2.ebuild b/dev-ml/ocurl/ocurl-0.9.2.ebuild
new file mode 100644
index 000000000000..f60438e9964a
--- /dev/null
+++ b/dev-ml/ocurl/ocurl-0.9.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="OCaml interface to the libcurl library"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocurl/ https://github.com/ygrek/ocurl"
+SRC_URI="https://github.com/ygrek/ocurl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="examples +ocamlopt"
+
+RDEPEND=">=net-misc/curl-7.9.8
+ dev-ml/lwt:=
+ dev-ml/camlp4:=
+ >=dev-lang/ocaml-3.12:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ emake -j1 all
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc CHANGES.txt README.md
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}