summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-22 14:46:29 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-22 16:24:34 +0200
commit0dc5e83d174cd5271de5c6829ee987844a9eb886 (patch)
tree02e20892f3aa1378db5377e4fb0655f42aacacb7 /dev-ml/js_of_ocaml
parentdev-util/patdiff: initial import (diff)
downloadgentoo-0dc5e83d174cd5271de5c6829ee987844a9eb886.tar.gz
gentoo-0dc5e83d174cd5271de5c6829ee987844a9eb886.tar.bz2
gentoo-0dc5e83d174cd5271de5c6829ee987844a9eb886.zip
dev-ml/js_of_ocaml: bump to 3.0.0 and update live ebuild
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/js_of_ocaml')
-rw-r--r--dev-ml/js_of_ocaml/Manifest1
-rw-r--r--dev-ml/js_of_ocaml/js_of_ocaml-3.0.0.ebuild75
-rw-r--r--dev-ml/js_of_ocaml/js_of_ocaml-9999.ebuild72
-rw-r--r--dev-ml/js_of_ocaml/metadata.xml2
4 files changed, 119 insertions, 31 deletions
diff --git a/dev-ml/js_of_ocaml/Manifest b/dev-ml/js_of_ocaml/Manifest
index 6a21ead28e5a..3790dbaf16c0 100644
--- a/dev-ml/js_of_ocaml/Manifest
+++ b/dev-ml/js_of_ocaml/Manifest
@@ -1 +1,2 @@
DIST js_of_ocaml-2.8.4.tar.gz 1344082 SHA256 74edd38a964fcee930778a908c896b5c9795f64fc34a3c58361ccfa441811725 SHA512 8dc65bac7d60f2d3534e31e0fddb061f1b97bfd8146b1a34b4a1a516574c6a39f66d115646aa9767b7e24a51ec76949b05841088601f97d76972c8899a50c4fd WHIRLPOOL bc444184519ae90d308ae4675078e1d5fd461ea32f4dccf5e74bab25f0a0e8ba49d229f951205effd676b337656633fb7046cd908c2167799253dcee0a61f20f
+DIST js_of_ocaml-3.0.0.tar.gz 1433377 SHA256 eb49ca6d66ac51a41cf611f1a6a85269d310dbc1711ac4b819c9a04ee53b5a4e SHA512 dc4bbbfdacb43338aa7f97b7012b6de8a2eac5d7c5f535ceb9565c477c961a212ce5b2a75b1719fcd9f2d57938ee2162f6f04d3364397a469d7a13d1fe4e3908 WHIRLPOOL a43b35000af7714f571f0cf373b529883063194ff0a4b57a9bae9670b257ee38288a5b8f4caf19b9ee18fdceeea0a2f5fc0f45cd503ebfa1281b657115a54fc1
diff --git a/dev-ml/js_of_ocaml/js_of_ocaml-3.0.0.ebuild b/dev-ml/js_of_ocaml/js_of_ocaml-3.0.0.ebuild
new file mode 100644
index 000000000000..3a44770cfb67
--- /dev/null
+++ b/dev-ml/js_of_ocaml/js_of_ocaml-3.0.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="A compiler from OCaml bytecode to javascript"
+HOMEPAGE="http://ocsigen.org/js_of_ocaml/"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/js_of_ocaml"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/js_of_ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+IUSE="+ocamlopt camlp4 lwt doc +deriving +ppx +xml test"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.12:=[ocamlopt?]
+
+ camlp4? ( dev-ml/camlp4:= )
+
+ dev-ml/cmdliner:=
+ dev-ml/cppo:=
+
+ lwt? ( >=dev-ml/lwt-2.4.4:= )
+
+ dev-ml/ocamlbuild:=
+
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_tools_versioned:=
+ dev-ml/uchar:=
+
+ ppx? ( dev-ml/ppx_tools:= dev-ml/ppx_deriving:= )
+
+ xml? ( >=dev-ml/tyxml-4:= dev-ml/reactiveData:= )
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? ( dev-util/patdiff )
+"
+REQUIRED_USE="xml? ( ppx )"
+
+src_compile() {
+ emake
+ use doc && emake doc
+}
+
+oinstall() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${1}.install || die
+}
+
+src_install() {
+ use camlp4 && oinstall js_of_ocaml-camlp4
+ oinstall js_of_ocaml-compiler
+ use lwt && oinstall js_of_ocaml-lwt
+ oinstall js_of_ocaml-ocamlbuild
+ oinstall js_of_ocaml
+ use ppx && oinstall js_of_ocaml-ppx
+ use ppx && oinstall js_of_ocaml-toplevel
+ use xml && oinstall js_of_ocaml-tyxml
+}
diff --git a/dev-ml/js_of_ocaml/js_of_ocaml-9999.ebuild b/dev-ml/js_of_ocaml/js_of_ocaml-9999.ebuild
index 5b17a890bb3f..3a44770cfb67 100644
--- a/dev-ml/js_of_ocaml/js_of_ocaml-9999.ebuild
+++ b/dev-ml/js_of_ocaml/js_of_ocaml-9999.ebuild
@@ -20,46 +20,56 @@ fi
LICENSE="LGPL-2.1-with-linking-exception"
SLOT="0/${PV}"
-IUSE="+ocamlopt doc +deriving +ppx +react +xml X"
+IUSE="+ocamlopt camlp4 lwt doc +deriving +ppx +xml test"
RDEPEND="
- >=dev-lang/ocaml-3.12:=[ocamlopt?,X?]
- >=dev-ml/lwt-2.4.4:=[camlp4(+)]
- react? ( dev-ml/react:= dev-ml/reactiveData:= )
- xml? ( >=dev-ml/tyxml-4:= )
- ppx? ( dev-ml/ppx_tools:= dev-ml/ppx_deriving:= dev-ml/ppx_driver:= )
+ >=dev-lang/ocaml-3.12:=[ocamlopt?]
+
+ camlp4? ( dev-ml/camlp4:= )
+
dev-ml/cmdliner:=
- dev-ml/menhir:=
- dev-ml/ocaml-base64:=
- dev-ml/camlp4:=
dev-ml/cppo:=
- dev-ml/uchar:=
+
+ lwt? ( >=dev-ml/lwt-2.4.4:= )
+
dev-ml/ocamlbuild:=
- dev-ml/yojson:=
- deriving? ( >=dev-ml/deriving-0.6:= )"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- printf "\n\n" >> Makefile.conf
- use ocamlopt || echo "BEST := byte" >> Makefile.conf
- use ocamlopt || echo "NATDYNLINK := NO" >> Makefile.conf
- use deriving || echo "WITH_DERIVING := NO" >> Makefile.conf
- use X || echo "WITH_GRAPHICS := NO" >> Makefile.conf
- use react || echo "WITH_REACT := NO" >> Makefile.conf
- use ppx || echo "WITH_PPX := NO" >> Makefile.conf
- use ppx || echo "WITH_PPX_DERIVING := NO" >> Makefile.conf
- use ppx || echo "WITH_PPX_DRIVER := NO" >> Makefile.conf
- echo "WITH_ASYNC := NO" >> Makefile.conf
-}
+
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_tools_versioned:=
+ dev-ml/uchar:=
+
+ ppx? ( dev-ml/ppx_tools:= dev-ml/ppx_deriving:= )
+
+ xml? ( >=dev-ml/tyxml-4:= dev-ml/reactiveData:= )
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? ( dev-util/patdiff )
+"
+REQUIRED_USE="xml? ( ppx )"
src_compile() {
- emake -j1
+ emake
use doc && emake doc
}
+oinstall() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${1}.install || die
+}
+
src_install() {
- findlib_src_preinst
- emake BINDIR="${ED}/usr/bin/" install
- dodoc CHANGES README.md
- use doc && dohtml -r doc/api/html/
+ use camlp4 && oinstall js_of_ocaml-camlp4
+ oinstall js_of_ocaml-compiler
+ use lwt && oinstall js_of_ocaml-lwt
+ oinstall js_of_ocaml-ocamlbuild
+ oinstall js_of_ocaml
+ use ppx && oinstall js_of_ocaml-ppx
+ use ppx && oinstall js_of_ocaml-toplevel
+ use xml && oinstall js_of_ocaml-tyxml
}
diff --git a/dev-ml/js_of_ocaml/metadata.xml b/dev-ml/js_of_ocaml/metadata.xml
index 904a7a4498e5..a7e813252c72 100644
--- a/dev-ml/js_of_ocaml/metadata.xml
+++ b/dev-ml/js_of_ocaml/metadata.xml
@@ -6,7 +6,9 @@
<name>Gentoo ML Project</name>
</maintainer>
<use>
+ <flag name="camlp4">Build with camlp4 syntax extensions.</flag>
<flag name="deriving">Enable <pkg>dev-ml/deriving</pkg> support for improving the type safety.</flag>
+ <flag name="lwt">Enable <pkg>dev-ml/lwt</pkg> support.</flag>
<flag name="ppx">Enables the ppx syntax extension</flag>
<flag name="react">Enable functionnal reactive programming support.</flag>
</use>