summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 19:04:58 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commitbdaf9fba93918ff5aa66100a76107b8955df02b2 (patch)
tree432385ce6f4b68d2328e2dc2f9c7250fe0a58191 /dev-ml/fieldslib
parentdev-ml/sexplib: use proper install method (diff)
downloadgentoo-bdaf9fba93918ff5aa66100a76107b8955df02b2.tar.gz
gentoo-bdaf9fba93918ff5aa66100a76107b8955df02b2.tar.bz2
gentoo-bdaf9fba93918ff5aa66100a76107b8955df02b2.zip
dev-ml/fieldslib: use proper install method
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/fieldslib')
-rw-r--r--dev-ml/fieldslib/fieldslib-113.24.00.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/dev-ml/fieldslib/fieldslib-113.24.00.ebuild b/dev-ml/fieldslib/fieldslib-113.24.00.ebuild
index 4345191d612d..5bf8dcb97bfd 100644
--- a/dev-ml/fieldslib/fieldslib-113.24.00.ebuild
+++ b/dev-ml/fieldslib/fieldslib-113.24.00.ebuild
@@ -8,18 +8,32 @@ OASIS_BUILD_DOCS=1
inherit oasis
-MY_P=${PN/-/_}-${PV}
DESCRIPTION="Folding over record fields"
HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
+RDEPEND=""
+DEPEND="${RDEPEND} dev-ml/opam"
-DOCS=( "CHANGES.md" )
-S="${WORKDIR}/${MY_P}"
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}