summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:32:28 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:49 +0100
commita40f529da7720579516028c9acd12064e585232d (patch)
treea7518cf82ec11f88b3f5b32acad43e736705dd0c /dev-lua
parentdev-lua/lualdap: update EAPI 7 -> 8 (diff)
downloadgentoo-a40f529da7720579516028c9acd12064e585232d.tar.gz
gentoo-a40f529da7720579516028c9acd12064e585232d.tar.bz2
gentoo-a40f529da7720579516028c9acd12064e585232d.zip
dev-lua/lualdap: drop 1.3.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lualdap/lualdap-1.3.0.ebuild89
1 files changed, 0 insertions, 89 deletions
diff --git a/dev-lua/lualdap/lualdap-1.3.0.ebuild b/dev-lua/lualdap/lualdap-1.3.0.ebuild
deleted file mode 100644
index adb9a117f3a7..000000000000
--- a/dev-lua/lualdap/lualdap-1.3.0.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="A lua binding for the OpenLDAP client libraries"
-HOMEPAGE="https://github.com/lualdap/lualdap"
-SRC_URI="https://github.com/lualdap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~sparc ~x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="test"
-
-RDEPEND="
- net-nds/openldap
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- test? ( ${RDEPEND} )
-"
-
-HTML_DOCS=( "docs/." )
-
-src_prepare() {
- default
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LBER_LIBDIR=/usr/$(get_libdir)"
- "LDAP_LIBDIR=/usr/$(get_libdir)"
- "LUA_INCDIR=$(lua_get_include_dir)"
- "LUA_LIBDIR=/usr/$(get_libdir)"
- )
-
- emake "${myemakeargs[@]}"
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_test() {
- pushd "${BUILD_DIR}" || die
- LUA_CPATH="./src/?.so" ${ELUA} tests/test.lua
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- # Workaround, as 'make install' does not create this directory
- dodir "$(lua_get_cmod_dir)"
-
- local myemakeargs=(
- "DESTDIR=${ED}"
- "INST_LIBDIR=$(lua_get_cmod_dir)"
- )
-
- emake "${myemakeargs[@]}" install
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}