summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:36:11 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:52 +0100
commit692a72d38832748649e30931e0e46804d3f9dcae (patch)
tree501a3d3a4b1afe5dc4fb7ae15a8a6bd74f84a381 /dev-lua
parentdev-lua/luasystem: update EAPI 7 -> 8 (diff)
downloadgentoo-692a72d38832748649e30931e0e46804d3f9dcae.tar.gz
gentoo-692a72d38832748649e30931e0e46804d3f9dcae.tar.bz2
gentoo-692a72d38832748649e30931e0e46804d3f9dcae.zip
dev-lua/luasystem: drop 0.2.1_p0-r102
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luasystem/luasystem-0.2.1_p0-r102.ebuild91
1 files changed, 0 insertions, 91 deletions
diff --git a/dev-lua/luasystem/luasystem-0.2.1_p0-r102.ebuild b/dev-lua/luasystem/luasystem-0.2.1_p0-r102.ebuild
deleted file mode 100644
index 3276dda4283d..000000000000
--- a/dev-lua/luasystem/luasystem-0.2.1_p0-r102.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-MY_PV="${PV/_p/-}"
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="Platform independent system calls for Lua"
-HOMEPAGE="https://github.com/o-lim/luasystem/"
-SRC_URI="https://github.com/o-lim/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="${LUA_DEPS}"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- test? (
- dev-lua/busted[${LUA_USEDEP}]
- dev-lua/lua_cliargs[${LUA_USEDEP}]
- ${RDEPEND}
- )
-"
-
-PATCHES=( "${FILESDIR}"/${P}-fix-makefile.patch )
-
-src_prepare() {
- default
-
- lua_copy_sources
-}
-
-lua_src_test() {
- busted --lua=${ELUA} || die
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LD=$(tc-getCC)"
- "LUAINC_linux=$(lua_get_include_dir)"
- "MYCFLAGS=${CFLAGS}"
- "MYLDFLAGS=${LDFLAGS}"
- )
-
- emake "${myemakeargs[@]}" linux
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_install () {
- pushd "${BUILD_DIR}" || die
-
- local emakeargs=(
- "INSTALL_TOP_CDIR=${ED}/$(lua_get_cmod_dir)"
- "INSTALL_TOP_LDIR=${ED}/$(lua_get_lmod_dir)"
- "LUA_INC=${ED}/$(lua_get_include_dir)"
- )
-
- emake "${emakeargs[@]}" install
-
- insinto $(lua_get_lmod_dir)/system
- doins system/init.lua
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}