summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:38:23 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:54 +0100
commit2e35ba6b12e2189193fa279c808f2346a7710cf8 (patch)
tree1e394f893e1522d494cb5af25fac817274ec77e0 /dev-lua
parentdev-lua/mpack: update EAPI 7 -> 8 (diff)
downloadgentoo-2e35ba6b12e2189193fa279c808f2346a7710cf8.tar.gz
gentoo-2e35ba6b12e2189193fa279c808f2346a7710cf8.tar.bz2
gentoo-2e35ba6b12e2189193fa279c808f2346a7710cf8.zip
dev-lua/mpack: drop 1.0.8-r100, 1.0.9
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/mpack/Manifest1
-rw-r--r--dev-lua/mpack/mpack-1.0.8-r100.ebuild113
-rw-r--r--dev-lua/mpack/mpack-1.0.9.ebuild113
3 files changed, 0 insertions, 227 deletions
diff --git a/dev-lua/mpack/Manifest b/dev-lua/mpack/Manifest
index fc341f3a2e87..00e09b45279c 100644
--- a/dev-lua/mpack/Manifest
+++ b/dev-lua/mpack/Manifest
@@ -1,2 +1 @@
-DIST mpack-1.0.8.tar.gz 15616 BLAKE2B 06593296d1d36459127bf35eaeb37c894a0c0c6ccff0969cd0a82bee1920a715801db26f0ba0bc54a56399d07efc262666ee4ce79878288a5c0221fd27febea1 SHA512 6d21cc6bbdee583a1d808742991459e4b1796f347b2f4eaa747b576f5bb1ca989123339120e43246bac859c20e6f46ac57116ce9f135157256fecbd8cf817f75
DIST mpack-1.0.9.tar.gz 16087 BLAKE2B 062f0deaa9ea359486933b5736591ea3ee78886e31259b721d88ef44762403185b881d076ca35fe6e8c16ab756d36698fec1ca893ab3667635e388456a8ad417 SHA512 c663a6cb29c1ae3f88baf25d36b076c35b35b96a16f9df472f8063009dc70886071cc27bf9224aceb86afb5c590ac072fd484435f40ecc4961eabfb5df08f395
diff --git a/dev-lua/mpack/mpack-1.0.8-r100.ebuild b/dev-lua/mpack/mpack-1.0.8-r100.ebuild
deleted file mode 100644
index b403ed3deab8..000000000000
--- a/dev-lua/mpack/mpack-1.0.8-r100.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-MY_PN="lib${PN}-lua"
-
-DESCRIPTION="Lua bindings for libmpack"
-HOMEPAGE="https://github.com/libmpack/libmpack-lua/"
-SRC_URI="https://github.com/${MY_PN/-lua/}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc x86 ~x64-macos"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/libmpack
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- test? (
- dev-lua/busted[${LUA_USEDEP}]
- dev-lua/lua_cliargs[${LUA_USEDEP}]
- ${RDEPEND}
- )
-"
-
-src_prepare() {
- default
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LUA_INCLUDE=$(lua_get_CFLAGS)"
- "LUA_LIB="
- "USE_SYSTEM_MPACK=yes"
- "USE_SYSTEM_LUA=yes"
- )
-
- emake "${myemakeargs[@]}"
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_test() {
- pushd "${BUILD_DIR}" || die
-
- # "[ FAILED ] test.lua @ 279: mpack should not leak memory"
- # It doesn't seem upstream actually support LuaJIT so were this up to me
- # I would drop it from LUA_COMPAT, unfortunately there are packages in the
- # tree which currently expect it to be supported.
- if [[ ${ELUA} == "luajit" ]]; then
- ewarn "Not running tests under ${ELUA} because they are known to fail"
- return
- fi
-
- busted --lua="${ELUA}" test.lua || die
-
- popd
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- local installdir="$(lua_get_cmod_dir)"
- local myemakeargs=(
- "DESTDIR=${ED}"
- "LUA_CMOD_INSTALLDIR=${installdir#$EPREFIX}"
- "USE_SYSTEM_MPACK=yes"
- "USE_SYSTEM_LUA=yes"
- )
-
- emake "${myemakeargs[@]}" install
-
- popd
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- local luav=$(lua_get_version)
- # we only want the major version (e.g. 5.1)
- local luamv=${luav:0:3}
- local file="lua/${luamv}/mpack.so"
- install_name_tool -id "${EPREFIX}/usr/$(get_libdir)/${file}" "${ED}/usr/$(get_libdir)/${file}" || die "Failed to adjust install_name"
- fi
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}
diff --git a/dev-lua/mpack/mpack-1.0.9.ebuild b/dev-lua/mpack/mpack-1.0.9.ebuild
deleted file mode 100644
index b403ed3deab8..000000000000
--- a/dev-lua/mpack/mpack-1.0.9.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-MY_PN="lib${PN}-lua"
-
-DESCRIPTION="Lua bindings for libmpack"
-HOMEPAGE="https://github.com/libmpack/libmpack-lua/"
-SRC_URI="https://github.com/${MY_PN/-lua/}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc x86 ~x64-macos"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/libmpack
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- test? (
- dev-lua/busted[${LUA_USEDEP}]
- dev-lua/lua_cliargs[${LUA_USEDEP}]
- ${RDEPEND}
- )
-"
-
-src_prepare() {
- default
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LUA_INCLUDE=$(lua_get_CFLAGS)"
- "LUA_LIB="
- "USE_SYSTEM_MPACK=yes"
- "USE_SYSTEM_LUA=yes"
- )
-
- emake "${myemakeargs[@]}"
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_test() {
- pushd "${BUILD_DIR}" || die
-
- # "[ FAILED ] test.lua @ 279: mpack should not leak memory"
- # It doesn't seem upstream actually support LuaJIT so were this up to me
- # I would drop it from LUA_COMPAT, unfortunately there are packages in the
- # tree which currently expect it to be supported.
- if [[ ${ELUA} == "luajit" ]]; then
- ewarn "Not running tests under ${ELUA} because they are known to fail"
- return
- fi
-
- busted --lua="${ELUA}" test.lua || die
-
- popd
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- local installdir="$(lua_get_cmod_dir)"
- local myemakeargs=(
- "DESTDIR=${ED}"
- "LUA_CMOD_INSTALLDIR=${installdir#$EPREFIX}"
- "USE_SYSTEM_MPACK=yes"
- "USE_SYSTEM_LUA=yes"
- )
-
- emake "${myemakeargs[@]}" install
-
- popd
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- local luav=$(lua_get_version)
- # we only want the major version (e.g. 5.1)
- local luamv=${luav:0:3}
- local file="lua/${luamv}/mpack.so"
- install_name_tool -id "${EPREFIX}/usr/$(get_libdir)/${file}" "${ED}/usr/$(get_libdir)/${file}" || die "Failed to adjust install_name"
- fi
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}