summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-11-01 02:03:45 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-11-01 02:04:06 +0100
commit8307f035451b51990325f11c560b87a5268421cf (patch)
treee4bf273bba59d605b7a21c129a15d2acf2bda2e6 /dev-lua/readline
parentdev-lua/readline: x86 stable (diff)
downloadgentoo-8307f035451b51990325f11c560b87a5268421cf.tar.gz
gentoo-8307f035451b51990325f11c560b87a5268421cf.tar.bz2
gentoo-8307f035451b51990325f11c560b87a5268421cf.zip
dev-lua/readline: drop 3.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/readline')
-rw-r--r--dev-lua/readline/Manifest1
-rw-r--r--dev-lua/readline/readline-3.1.ebuild94
2 files changed, 0 insertions, 95 deletions
diff --git a/dev-lua/readline/Manifest b/dev-lua/readline/Manifest
index 05cc92564ecb..d990d6c6983f 100644
--- a/dev-lua/readline/Manifest
+++ b/dev-lua/readline/Manifest
@@ -1,2 +1 @@
-DIST lua-readline-3.1.tar.gz 16114 BLAKE2B 372bc61573b20c8ebf66bb684624dde9d5ce7868543294450ef3d47bba5a042c5d7f4262366f2de2db8d3d92bbf7fb4895d29577af34307d7b145e6f913ec957 SHA512 d3bee61b6c876e96d2c1097e29862a3f16d1e666b1087e58899f59a3115f9af31793492edfcc3f3802565f98f276960d382a89c0b6cfb1d54acfd37ad006b74b
DIST lua-readline-3.2.tar.gz 16215 BLAKE2B 889db8cfefc37008fac9f92b6ef071147763d00f01ca42b31646594e812ab936187e65e8959e723be409d21c3e3cc2d93fe52eafac79e37b7d0cec2216d8accf SHA512 d605b99f2fa06920e67125b462f257f8cd263912b6ffba173bee77425c77f6b08b463ec4c0851c81dfc23e736698c9fbbb40e8a935cada2329b6a8e02a6cdaad
diff --git a/dev-lua/readline/readline-3.1.ebuild b/dev-lua/readline/readline-3.1.ebuild
deleted file mode 100644
index 7d1172e9d37d..000000000000
--- a/dev-lua/readline/readline-3.1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="A simple interface to the readline and history libraries"
-HOMEPAGE="https://pjb.com.au/comp/lua/readline.html"
-SRC_URI="https://pjb.com.au/comp/lua/${P}.tar.gz -> lua-${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-# Tests are interactive
-RESTRICT="test"
-
-RDEPEND="
- dev-lua/luaposix
- sys-libs/readline:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_prepare() {
- default
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local compiler=(
- "$(tc-getCC)"
- "${CFLAGS}"
- "-fPIC"
- "$(lua_get_CFLAGS)"
- "-c C-readline.c"
- "-o C-readline.o"
- )
- einfo "${compiler[@]}"
- ${compiler[@]} || die
-
- local linker=(
- "$(tc-getCC)"
- "-shared"
- "${LDFLAGS}"
- "$($(tc-getPKG_CONFIG) --libs readline)"
- "-o C-readline.so"
- "C-readline.o"
- )
- einfo "${linker[@]}"
- ${linker[@]} || die
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_test() {
- pushd "${BUILD_DIR}" || die
- LUA_CPATH="./?.so;${ESYSROOT}/usr/$(get_libdir)/lua/$(ver_cut 1-2 $(lua_get_version))/?.so" ${ELUA} test/test_rl.lua || die
- popd || die
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- insinto "$(lua_get_cmod_dir)"
- doins C-readline.so
-
- insinto "$(lua_get_lmod_dir)"
- doins readline.lua
-
- popd || die
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- docinto html
- dodoc doc/readline.html
-}