summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-06-08 18:53:02 +0200
committerUlrich Müller <ulm@gentoo.org>2024-06-08 19:40:01 +0200
commit18e06fedc3cc5679d47773e08b0ac23fe8a83368 (patch)
treed7f8c31ae1b8a2eb210b5bcbb19e88020f1e17d5 /dev-lisp
parentmedia-libs/liblingoteach: drop 0.2.3 (diff)
downloadgentoo-18e06fedc3cc5679d47773e08b0ac23fe8a83368.tar.gz
gentoo-18e06fedc3cc5679d47773e08b0ac23fe8a83368.tar.bz2
gentoo-18e06fedc3cc5679d47773e08b0ac23fe8a83368.zip
dev-lisp/cl-ppcre: Update EAPI from 6 to 7
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-ppcre/cl-ppcre-2.1.0-r1.ebuild (renamed from dev-lisp/cl-ppcre/cl-ppcre-2.1.0.ebuild)14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-lisp/cl-ppcre/cl-ppcre-2.1.0.ebuild b/dev-lisp/cl-ppcre/cl-ppcre-2.1.0-r1.ebuild
index 668039a6537c..d0ad9237a47d 100644
--- a/dev-lisp/cl-ppcre/cl-ppcre-2.1.0.ebuild
+++ b/dev-lisp/cl-ppcre/cl-ppcre-2.1.0-r1.ebuild
@@ -1,26 +1,26 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit common-lisp-3
DESCRIPTION="CL-PPCRE is a portable regular expression library for Common Lisp"
-HOMEPAGE="http://weitz.de/cl-ppcre/
- http://www.cliki.net/cl-ppcre"
+HOMEPAGE="https://edicl.github.io/cl-ppcre/
+ https://www.cliki.net/cl-ppcre"
SRC_URI="https://github.com/edicl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
RDEPEND="dev-lisp/flexi-streams"
PDEPEND="dev-lisp/cl-ppcre-unicode"
src_unpack() {
- unpack ${A} && cd "${S}"
- rm -rf cl-ppcre-unicode test/unicode*
+ unpack ${A}
+ cd "${S}" || die
+ rm -rf cl-ppcre-unicode test/unicode* || die
}
src_install() {