summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-09-12 19:16:56 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-09-12 21:37:43 +0300
commit75b2fa612d4902f5714b03a979cd9e4d88cbeb3d (patch)
tree508419c48ba10a43a1535ee066c8264f15643b33 /dev-lisp/clisp
parent*/*: drop ia64 from depends (diff)
downloadgentoo-75b2fa612d4902f5714b03a979cd9e4d88cbeb3d.tar.gz
gentoo-75b2fa612d4902f5714b03a979cd9e4d88cbeb3d.tar.bz2
gentoo-75b2fa612d4902f5714b03a979cd9e4d88cbeb3d.zip
*/*: remove use ia64 calls
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-lisp/clisp')
-rw-r--r--dev-lisp/clisp/clisp-2.49.92-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-lisp/clisp/clisp-2.49.92-r1.ebuild b/dev-lisp/clisp/clisp-2.49.92-r1.ebuild
index 0dc11d331db4..65008e851be2 100644
--- a/dev-lisp/clisp/clisp-2.49.92-r1.ebuild
+++ b/dev-lisp/clisp/clisp-2.49.92-r1.ebuild
@@ -54,8 +54,8 @@ BUILDDIR="builddir"
# * oracle: can't install oracle-instantclient
src_prepare() {
- # More than -O1 breaks alpha/ia64
- if use alpha || use ia64; then
+ # More than -O1 breaks alpha
+ if use alpha; then
sed -i -e 's/-O2//g' src/makemake.in || die
fi
eapply "${FILESDIR}"/"${P}"-after_glibc_cfree_bdb.patch
@@ -70,8 +70,8 @@ src_configure() {
# https://gitlab.com/gnu-clisp/clisp/-/issues/49
filter-lto
- # We need this to build on alpha/ia64
- if use alpha || use ia64; then
+ # We need this to build on alpha
+ if use alpha; then
replace-flags -O? -O1
fi