summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilfried Holzke <gentoo@holzke.net>2020-01-02 12:08:37 +0100
committerCraig Andrews <candrews@gentoo.org>2020-01-02 07:48:52 -0500
commitc9c49d2a736f2475806eacae920e04d56285bf58 (patch)
tree6ba787a79a1857f4aef0d750939aa256d822f378 /dev-libs
parentnet-misc/socket-burst-dampener: Bump to version 1.2.1 (diff)
downloadgentoo-c9c49d2a736f2475806eacae920e04d56285bf58.tar.gz
gentoo-c9c49d2a736f2475806eacae920e04d56285bf58.tar.bz2
gentoo-c9c49d2a736f2475806eacae920e04d56285bf58.zip
dev-libs/roct-thunk-interface: cmake-utils.eclass -> cmake.eclass
Signed-off-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-2.3.79, Repoman-2.3.16 Closes: https://github.com/gentoo/gentoo/pull/14215 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/roct-thunk-interface/roct-thunk-interface-2.0.0.ebuild6
-rw-r--r--dev-libs/roct-thunk-interface/roct-thunk-interface-2.10.0.ebuild12
-rw-r--r--dev-libs/roct-thunk-interface/roct-thunk-interface-2.6.0.ebuild10
-rw-r--r--dev-libs/roct-thunk-interface/roct-thunk-interface-2.7.0.ebuild10
-rw-r--r--dev-libs/roct-thunk-interface/roct-thunk-interface-2.8.0.ebuild10
-rw-r--r--dev-libs/roct-thunk-interface/roct-thunk-interface-2.9.0-r1.ebuild12
-rw-r--r--dev-libs/roct-thunk-interface/roct-thunk-interface-3.0.0.ebuild12
-rw-r--r--dev-libs/roct-thunk-interface/roct-thunk-interface-9999.ebuild12
8 files changed, 42 insertions, 42 deletions
diff --git a/dev-libs/roct-thunk-interface/roct-thunk-interface-2.0.0.ebuild b/dev-libs/roct-thunk-interface/roct-thunk-interface-2.0.0.ebuild
index ba407458247a..2b55522fb864 100644
--- a/dev-libs/roct-thunk-interface/roct-thunk-interface-2.0.0.ebuild
+++ b/dev-libs/roct-thunk-interface/roct-thunk-interface-2.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils linux-info
+inherit cmake linux-info
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/"
@@ -29,5 +29,5 @@ DEPEND="${RDEPEND}"
src_prepare() {
sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
diff --git a/dev-libs/roct-thunk-interface/roct-thunk-interface-2.10.0.ebuild b/dev-libs/roct-thunk-interface/roct-thunk-interface-2.10.0.ebuild
index 8309cffdc300..f3191cff1c27 100644
--- a/dev-libs/roct-thunk-interface/roct-thunk-interface-2.10.0.ebuild
+++ b/dev-libs/roct-thunk-interface/roct-thunk-interface-2.10.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils linux-info
+inherit cmake linux-info
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/"
@@ -26,18 +26,18 @@ DEPEND="${RDEPEND}"
src_prepare() {
sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/"
-DCPACK_PACKAGING_INSTALL_PREFIX="${EPREFIX}/usr"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile build-dev
+ cmake_src_compile build-dev
}
src_install() {
- cmake-utils_src_install install-dev
+ cmake_src_install install-dev
}
diff --git a/dev-libs/roct-thunk-interface/roct-thunk-interface-2.6.0.ebuild b/dev-libs/roct-thunk-interface/roct-thunk-interface-2.6.0.ebuild
index 69e6b7fe853e..d5524e85d8c6 100644
--- a/dev-libs/roct-thunk-interface/roct-thunk-interface-2.6.0.ebuild
+++ b/dev-libs/roct-thunk-interface/roct-thunk-interface-2.6.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils linux-info
+inherit cmake linux-info
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/"
@@ -32,11 +32,11 @@ DEPEND="${RDEPEND}"
src_prepare() {
sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_compile() {
- cmake-utils_src_compile build-dev
+ cmake_src_compile build-dev
}
src_install() {
- cmake-utils_src_install install-dev
+ cmake_src_install install-dev
}
diff --git a/dev-libs/roct-thunk-interface/roct-thunk-interface-2.7.0.ebuild b/dev-libs/roct-thunk-interface/roct-thunk-interface-2.7.0.ebuild
index e7eb65985846..34aec03c20ba 100644
--- a/dev-libs/roct-thunk-interface/roct-thunk-interface-2.7.0.ebuild
+++ b/dev-libs/roct-thunk-interface/roct-thunk-interface-2.7.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils linux-info
+inherit cmake linux-info
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/"
@@ -32,11 +32,11 @@ DEPEND="${RDEPEND}"
src_prepare() {
sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_compile() {
- cmake-utils_src_compile build-dev
+ cmake_src_compile build-dev
}
src_install() {
- cmake-utils_src_install install-dev
+ cmake_src_install install-dev
}
diff --git a/dev-libs/roct-thunk-interface/roct-thunk-interface-2.8.0.ebuild b/dev-libs/roct-thunk-interface/roct-thunk-interface-2.8.0.ebuild
index 454c65e73c12..651c8c64956b 100644
--- a/dev-libs/roct-thunk-interface/roct-thunk-interface-2.8.0.ebuild
+++ b/dev-libs/roct-thunk-interface/roct-thunk-interface-2.8.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils linux-info
+inherit cmake linux-info
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/"
@@ -32,11 +32,11 @@ DEPEND="${RDEPEND}"
src_prepare() {
sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_compile() {
- cmake-utils_src_compile build-dev
+ cmake_src_compile build-dev
}
src_install() {
- cmake-utils_src_install install-dev
+ cmake_src_install install-dev
}
diff --git a/dev-libs/roct-thunk-interface/roct-thunk-interface-2.9.0-r1.ebuild b/dev-libs/roct-thunk-interface/roct-thunk-interface-2.9.0-r1.ebuild
index 8309cffdc300..f3191cff1c27 100644
--- a/dev-libs/roct-thunk-interface/roct-thunk-interface-2.9.0-r1.ebuild
+++ b/dev-libs/roct-thunk-interface/roct-thunk-interface-2.9.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils linux-info
+inherit cmake linux-info
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/"
@@ -26,18 +26,18 @@ DEPEND="${RDEPEND}"
src_prepare() {
sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/"
-DCPACK_PACKAGING_INSTALL_PREFIX="${EPREFIX}/usr"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile build-dev
+ cmake_src_compile build-dev
}
src_install() {
- cmake-utils_src_install install-dev
+ cmake_src_install install-dev
}
diff --git a/dev-libs/roct-thunk-interface/roct-thunk-interface-3.0.0.ebuild b/dev-libs/roct-thunk-interface/roct-thunk-interface-3.0.0.ebuild
index 8309cffdc300..f3191cff1c27 100644
--- a/dev-libs/roct-thunk-interface/roct-thunk-interface-3.0.0.ebuild
+++ b/dev-libs/roct-thunk-interface/roct-thunk-interface-3.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils linux-info
+inherit cmake linux-info
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/"
@@ -26,18 +26,18 @@ DEPEND="${RDEPEND}"
src_prepare() {
sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/"
-DCPACK_PACKAGING_INSTALL_PREFIX="${EPREFIX}/usr"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile build-dev
+ cmake_src_compile build-dev
}
src_install() {
- cmake-utils_src_install install-dev
+ cmake_src_install install-dev
}
diff --git a/dev-libs/roct-thunk-interface/roct-thunk-interface-9999.ebuild b/dev-libs/roct-thunk-interface/roct-thunk-interface-9999.ebuild
index 8309cffdc300..f3191cff1c27 100644
--- a/dev-libs/roct-thunk-interface/roct-thunk-interface-9999.ebuild
+++ b/dev-libs/roct-thunk-interface/roct-thunk-interface-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils linux-info
+inherit cmake linux-info
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/"
@@ -26,18 +26,18 @@ DEPEND="${RDEPEND}"
src_prepare() {
sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/"
-DCPACK_PACKAGING_INSTALL_PREFIX="${EPREFIX}/usr"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile build-dev
+ cmake_src_compile build-dev
}
src_install() {
- cmake-utils_src_install install-dev
+ cmake_src_install install-dev
}