summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAliaksei Urbanski <aliaksei.urbanski@gmail.com>2024-11-15 10:37:36 +0300
committerPacho Ramos <pacho@gentoo.org>2024-11-17 13:02:03 +0100
commit097b4fc1ddb0fe431622bd69709e110b949f260f (patch)
treeb9f1ef3ee68e5d4d233f766185f5b2f419858cd2 /dev-libs
parentmedia-fonts/noto-emoji: fix VariableOrderWrong warning (diff)
downloadgentoo-097b4fc1ddb0fe431622bd69709e110b949f260f.tar.gz
gentoo-097b4fc1ddb0fe431622bd69709e110b949f260f.tar.bz2
gentoo-097b4fc1ddb0fe431622bd69709e110b949f260f.zip
dev-libs/appstream-glib: add 0.8.3
News: - https://github.com/hughsie/appstream-glib/blob/appstream_glib_0_8_3/NEWS Changes in comparison to 0.8.2: - drop stemmer USE flag Closes: https://bugs.gentoo.org/922753 Signed-off-by: Aliaksei Urbanski <aliaksei.urbanski@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39330 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/appstream-glib/Manifest1
-rw-r--r--dev-libs/appstream-glib/appstream-glib-0.8.3.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/appstream-glib/Manifest b/dev-libs/appstream-glib/Manifest
index ab2a38f0357b..f8fe51289368 100644
--- a/dev-libs/appstream-glib/Manifest
+++ b/dev-libs/appstream-glib/Manifest
@@ -1 +1,2 @@
DIST appstream-glib-0.8.2.tar.xz 2320880 BLAKE2B 6c3c90298ae8bf362caea8c46643afaaab0bb0071271f5244eeca9356ed96a6a956c1b2ffa4a8500201e4bc494a54a15b3db4937b81c6f5f8b80f83299ac58ee SHA512 c9c21049ab43f5da8595aa07a3c2e097163a05b5e0fc030e4e3326136cd18127f04ad9edf08c12aea823b89048b43808cc60759cc26fcf2541cd9c1acbb29e28
+DIST appstream-glib-0.8.3.tar.xz 2322068 BLAKE2B 672ad96e6da162fe7afa9112edd38923d0e58df4837381622698297be778ea7d5eb3b056e23dd7fe469acfd94942a425edbbb7cb48fea09457cf3dd2615aea10 SHA512 df4247b710cf234eef037f5f7be6be4872638d0686becd65e10e6a4214b0dd1b48ffbbd69179f3fb9777373926840d5b776e20a41ce11d4926114345944db127
diff --git a/dev-libs/appstream-glib/appstream-glib-0.8.3.ebuild b/dev-libs/appstream-glib/appstream-glib-0.8.3.ebuild
new file mode 100644
index 000000000000..08743ee38174
--- /dev/null
+++ b/dev-libs/appstream-glib/appstream-glib-0.8.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg meson
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="https://people.freedesktop.org/~hughsient/appstream-glib/ https://github.com/hughsie/appstream-glib"
+SRC_URI="https://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/8" # soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="gtk-doc fonts +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.58.0:2
+ sys-apps/util-linux
+ app-arch/libarchive:=
+ >=net-misc/curl-7.56.0
+ >=dev-libs/json-glib-1.1.2
+ >=x11-libs/gdk-pixbuf-2.31.5:2[introspection?]
+
+ fonts? (
+ x11-libs/gtk+:3
+ >=media-libs/freetype-2.4:2
+ )
+ >=media-libs/fontconfig-2.11:1.0
+ dev-libs/libyaml
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-util/gperf
+
+ dev-libs/libxml2:2
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.9
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddep11=true
+ -Dbuilder=true
+ -Drpm=false
+ -Dalpm=false
+ $(meson_use fonts)
+ -Dman=true
+ $(meson_use gtk-doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}