summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /dev-libs/yaz
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/yaz')
-rw-r--r--dev-libs/yaz/yaz-3.0.53.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-libs/yaz/yaz-3.0.53.ebuild b/dev-libs/yaz/yaz-3.0.53.ebuild
index 66af93b48754..028369d37be8 100644
--- a/dev-libs/yaz/yaz-3.0.53.ebuild
+++ b/dev-libs/yaz/yaz-3.0.53.ebuild
@@ -40,12 +40,12 @@ src_configure() {
}
src_compile() {
- emake || die "emake failed"
+ emake
}
src_install() {
local docdir="/usr/share/doc/${PF}"
- emake DESTDIR="${D}" docdir="${docdir}" install || die "install failed"
+ emake DESTDIR="${D}" docdir="${docdir}" install
dodir ${docdir}/html
mv -f "${D}"/${docdir}/*.{html,png} "${D}"/${docdir}/html/ || die "Failed to move HTML docs"