summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-12 22:30:12 +0100
committerSam James <sam@gentoo.org>2024-07-12 22:30:18 +0100
commit919d935a4f5068b50598db0ac2beae8460d8f667 (patch)
tree381e745a160b535c4bffaac945aafea8abf07cc1 /dev-libs/xalan-c
parentnet-im/swift: build fixes (diff)
downloadgentoo-919d935a4f5068b50598db0ac2beae8460d8f667.tar.gz
gentoo-919d935a4f5068b50598db0ac2beae8460d8f667.tar.bz2
gentoo-919d935a4f5068b50598db0ac2beae8460d8f667.zip
dev-libs/xalan-c: fix build w/ icu-75
Closes: https://bugs.gentoo.org/934471 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/xalan-c')
-rw-r--r--dev-libs/xalan-c/files/xalan-c-1.12-icu-75.patch15
-rw-r--r--dev-libs/xalan-c/xalan-c-1.12-r2.ebuild1
-rw-r--r--dev-libs/xalan-c/xalan-c-9999.ebuild3
3 files changed, 18 insertions, 1 deletions
diff --git a/dev-libs/xalan-c/files/xalan-c-1.12-icu-75.patch b/dev-libs/xalan-c/files/xalan-c-1.12-icu-75.patch
new file mode 100644
index 000000000000..0e272187d0e2
--- /dev/null
+++ b/dev-libs/xalan-c/files/xalan-c-1.12-icu-75.patch
@@ -0,0 +1,15 @@
+>= ICU 75 needs C++17, see https://bugs.gentoo.org/934471.
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -32,9 +32,9 @@ if (POLICY CMP0067)
+ cmake_policy(SET CMP0067 NEW)
+ endif(POLICY CMP0067)
+
+-# Try C++14, then fall back to C++11 and C++98. Used for feature tests
++# Try C++17, then fall back to C++14, then C++11, and C++98. Used for feature tests
+ # for optional features.
+-set(CMAKE_CXX_STANDARD 14)
++set(CMAKE_CXX_STANDARD 17)
+
+ # Use folders (for IDE project grouping)
+ set_property(GLOBAL PROPERTY USE_FOLDERS ON)
diff --git a/dev-libs/xalan-c/xalan-c-1.12-r2.ebuild b/dev-libs/xalan-c/xalan-c-1.12-r2.ebuild
index 6a2473fc1c7f..beb96a63de6f 100644
--- a/dev-libs/xalan-c/xalan-c-1.12-r2.ebuild
+++ b/dev-libs/xalan-c/xalan-c-1.12-r2.ebuild
@@ -44,6 +44,7 @@ BDEPEND+="
PATCHES=(
"${FILESDIR}"/${P}-fix-lto.patch
"${FILESDIR}"/${P}-fix-threads.patch
+ "${FILESDIR}"/${P}-icu-75.patch
)
src_configure() {
diff --git a/dev-libs/xalan-c/xalan-c-9999.ebuild b/dev-libs/xalan-c/xalan-c-9999.ebuild
index 88309b909407..13753c18e646 100644
--- a/dev-libs/xalan-c/xalan-c-9999.ebuild
+++ b/dev-libs/xalan-c/xalan-c-9999.ebuild
@@ -16,7 +16,7 @@ if [[ ${PV} == *9999 ]]; then
else
inherit verify-sig
SRC_URI="
- mirror://apache/xalan/xalan-c/sources/${MY_PN}-${PV}.tar.gz
+ https://dlcdn.apache.org/xalan/xalan-c/sources/${MY_PN}-${PV}.tar.gz
verify-sig? ( https://dlcdn.apache.org/xalan/xalan-c/sources/${MY_PN}-${PV}.tar.gz.asc )
"
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/apache-xalan-c.asc
@@ -43,6 +43,7 @@ BDEPEND+="
PATCHES=(
"${FILESDIR}"/${PN}-1.12-fix-lto.patch
+ "${FILESDIR}"/${PN}-1.12-icu-75.patch
)
src_configure() {